Ключевое слово в защите информации
КЛЮЧЕВОЕ СЛОВО
в защите информации
Получить ГОСТ TLS-сертификат для домена (SSL-сертификат)
Добро пожаловать, Гость! Чтобы использовать все возможности Вход или Регистрация.

Уведомление

Icon
Error

Опции
К последнему сообщению К первому непрочитанному
Offline L_DelOff  
#1 Оставлено : 14 октября 2021 г. 12:39:01(UTC)
L_DelOff

Статус: Новичок

Группы: Участники
Зарегистрирован: 14.10.2021(UTC)
Сообщений: 3

Сказал(а) «Спасибо»: 1 раз
Доброго времени суток!
Задача: развернуть httpd (Apache/2.4.6) на RHEL 7.9.

Пытаюсь провести аналогию с данной инструкцией.


При попытке запустить httpd получаю
Код:
httpd: Syntax error on line 5 of /etc/httpd/conf/httpd.conf: Syntax error on line 2 of /etc/httpd/conf.modules.d/00-ssl.conf: Cannot load /opt/cprocsp/lib/amd64/mod_ssl.so into server: /opt/cprocsp/lib/amd64/mod_ssl.so: undefined symbol: ap_switch_protocol
Offline Андрей Русев  
#2 Оставлено : 18 октября 2021 г. 10:29:59(UTC)
Андрей Русев

Статус: Сотрудник

Группы: Администраторы, Участники
Зарегистрирован: 16.04.2008(UTC)
Сообщений: 836

Сказал(а) «Спасибо»: 2 раз
Поблагодарили: 210 раз в 163 постах
Здравствуйте.
Для дистрибутивов на базе RHEL/CentOS есть отдельная инструкция: https://support.cryptopr...vnija-po-gost-n-redos-73
Официальная техподдержка. Официальная база знаний.
Offline L_DelOff  
#3 Оставлено : 18 октября 2021 г. 11:26:29(UTC)
L_DelOff

Статус: Новичок

Группы: Участники
Зарегистрирован: 14.10.2021(UTC)
Сообщений: 3

Сказал(а) «Спасибо»: 1 раз
Попробовал с учётом новой инструкции. Аналогично:
Код:
httpd: Syntax error on line 5 of /etc/httpd/conf/httpd.conf: Syntax error on line 2 of /etc/httpd/conf.modules.d/00-ssl.conf: Cannot load /opt/cprocsp/lib/amd64/mod_ssl.so into server: /opt/cprocsp/lib/amd64/mod_ssl.so: undefined symbol: ap_switch_protocol
Offline Андрей Русев  
#4 Оставлено : 19 октября 2021 г. 17:25:09(UTC)
Андрей Русев

Статус: Сотрудник

Группы: Администраторы, Участники
Зарегистрирован: 16.04.2008(UTC)
Сообщений: 836

Сказал(а) «Спасибо»: 2 раз
Поблагодарили: 210 раз в 163 постах
Полагаю, всё потому, что у вас старый Apache: https://www.cryptopro.ru...sp/tls/gost-nginx-apache : нужен 2.4.25+
Официальная техподдержка. Официальная база знаний.
thanks 1 пользователь поблагодарил Андрей Русев за этот пост.
L_DelOff оставлено 28.10.2021(UTC)
Offline L_DelOff  
#5 Оставлено : 28 октября 2021 г. 9:30:53(UTC)
L_DelOff

Статус: Новичок

Группы: Участники
Зарегистрирован: 14.10.2021(UTC)
Сообщений: 3

Сказал(а) «Спасибо»: 1 раз
Установка более свежего apache помогла, спасибо

Server version: Apache/2.4.35 (IUS)
RSS Лента  Atom Лента
Пользователи, просматривающие эту тему
Быстрый переход  
Вы не можете создавать новые темы в этом форуме.
Вы не можете отвечать в этом форуме.
Вы не можете удалять Ваши сообщения в этом форуме.
Вы не можете редактировать Ваши сообщения в этом форуме.
Вы не можете создавать опросы в этом форуме.
Вы не можете голосовать в этом форуме.