Ключевое слово в защите информации
КЛЮЧЕВОЕ СЛОВО
в защите информации
Наши способы организации безопасного удалённого доступа к рабочим местам и корпоративным ресурсам
Добро пожаловать, Гость! Чтобы использовать все возможности Вход или Регистрация.

Уведомление

Icon
Error

Опции
К последнему сообщению К первому непрочитанному
Offline brenli  
#1 Оставлено : 23 февраля 2020 г. 14:25:11(UTC)
brenli

Статус: Участник

Группы: Участники
Зарегистрирован: 11.02.2020(UTC)
Сообщений: 11
Российская Федерация

Доброго времени.
Вопрос в теме.
Offline Андрей *  
#2 Оставлено : 23 февраля 2020 г. 14:31:59(UTC)
Андрей *

Статус: Сотрудник

Группы: Участники
Зарегистрирован: 26.07.2011(UTC)
Сообщений: 9,199
Мужчина
Российская Федерация

Сказал «Спасибо»: 336 раз
Поблагодарили: 1330 раз в 1034 постах
Здравствуйте.

Язык программирования?

Ключевые слова для поиска по форуму:
CAPICOM
CADESCOM

Примеров много, даже в самом SDK CAPICOM от MS.

Техническую поддержку оказываем тут
Наша база знаний
Offline brenli  
#3 Оставлено : 23 февраля 2020 г. 14:41:18(UTC)
brenli

Статус: Участник

Группы: Участники
Зарегистрирован: 11.02.2020(UTC)
Сообщений: 11
Российская Федерация

Автор: Андрей * Перейти к цитате
Здравствуйте.

Язык программирования?

Ключевые слова для поиска по форуму:
CAPICOM
CADESCOM

Примеров много, даже в самом SDK CAPICOM от MS.



Язык 1С 7.7 / JS / VB .
Можете ссылку конкретно на пример с открепленной подписью ?
Online Санчир Момолдаев  
#4 Оставлено : 23 февраля 2020 г. 16:03:06(UTC)
Санчир Момолдаев

Статус: Сотрудник

Группы: Участники
Зарегистрирован: 03.12.2018(UTC)
Сообщений: 309
Российская Федерация

Сказал(а) «Спасибо»: 39 раз
Поблагодарили: 41 раз в 41 постах
Автор: brenli Перейти к цитате

Язык 1С 7.7 / JS / VB .
Можете ссылку конкретно на пример с открепленной подписью ?


Код:
oSigner = Новый COMОбъект("CAdESCOM.CPSigner");
oSigner.Certificate = ПолучитьСертификатПоОтпечатку(СтрЗаменить("", " ", ""));
oSigner.TSAAddress = "http://www.cryptopro.ru/tsp/tsp.srf";

oSignedData = Новый COMОбъект("CAdESCOM.CadesSignedData");
oSignedData.ContentEncoding =1;
oSignedData.Content = Base64Строка(Новый ДвоичныеДанные("исходник"));

CADESCOM_CADES_TYPE = 1;
bDetached = истина;
EncodingType = 1;

sSignedMessage = oSignedData.SignCades(oSigner, CADESCOM_CADES_TYPE, bDetached);


CADESCOM_CADES_TYPE

bDetached - отделенная(true) или совмещенная (false)

Отредактировано пользователем 23 февраля 2020 г. 16:04:23(UTC)  | Причина: Не указана

Техническую поддержку оказываем тут
Наша база знаний
Offline Андрей *  
#5 Оставлено : 23 февраля 2020 г. 16:19:06(UTC)
Андрей *

Статус: Сотрудник

Группы: Участники
Зарегистрирован: 26.07.2011(UTC)
Сообщений: 9,199
Мужчина
Российская Федерация

Сказал «Спасибо»: 336 раз
Поблагодарили: 1330 раз в 1034 постах
Еще вариант:
...
oSigner.Certificate = ПолучитьСертификатИзХранилищаСертификатовWindows(СерийныйНомер);
...


Код:

&НаКлиенте
Функция ПолучитьСертификатИзХранилищаСертификатовWindows(СерийныйНомерСертификата);
	
	CAPICOM_CURRENT_USER_STORE = 2;
	
	oStore = Новый COMОбъект("CAdESCOM.Store");
   	oStore.Open(CAPICOM_CURRENT_USER_STORE);
	 
	Для Каждого oCert из oStore.Certificates Цикл 
		Если (oCert.SerialNumber = СерийныйНомерСертификата) тогда
			Возврат(oCert)
     	КонецЕсли;
   	КонецЦикла;
	
КонецФункции	


//если вместо CAdESCOM - CAPICOM, то заменить на Новый COMОбъект("CAPICOM.Store");

или использовать функции поиска, по отпечатку

Отредактировано пользователем 23 февраля 2020 г. 16:19:49(UTC)  | Причина: Не указана

Техническую поддержку оказываем тут
Наша база знаний
Offline Андрей *  
#6 Оставлено : 23 февраля 2020 г. 16:24:31(UTC)
Андрей *

Статус: Сотрудник

Группы: Участники
Зарегистрирован: 26.07.2011(UTC)
Сообщений: 9,199
Мужчина
Российская Федерация

Сказал «Спасибо»: 336 раз
Поблагодарили: 1330 раз в 1034 постах
Автор: brenli Перейти к цитате

Язык 1С 7.7 / JS / VB .
Можете ссылку конкретно на пример с открепленной подписью ?


https://forum.mista.ru/t...php?id=811721&page=1


p.s.
а если CAdESCOM\CAPICOM - нет в ОС?
МенеджерКриптографии из 1С - не предлагать?

https://www.cryptopro.ru...ts&m=29089#post29089

Техническую поддержку оказываем тут
Наша база знаний
RSS Лента  Atom Лента
Пользователи, просматривающие эту тему
Быстрый переход  
Вы не можете создавать новые темы в этом форуме.
Вы не можете отвечать в этом форуме.
Вы не можете удалять Ваши сообщения в этом форуме.
Вы не можете редактировать Ваши сообщения в этом форуме.
Вы не можете создавать опросы в этом форуме.
Вы не можете голосовать в этом форуме.