Ключевое слово в защите информации
КЛЮЧЕВОЕ СЛОВО
в защите информации
Получить ГОСТ TLS-сертификат для домена (SSL-сертификат)
Добро пожаловать, Гость! Чтобы использовать все возможности Вход или Регистрация.

Уведомление

Icon
Error

Опции
К последнему сообщению К первому непрочитанному
Offline doubleside  
#1 Оставлено : 30 ноября 2018 г. 8:52:53(UTC)
doubleside

Статус: Активный участник

Группы: Участники
Зарегистрирован: 23.05.2018(UTC)
Сообщений: 71
Великобритания
Откуда: London

Сказал(а) «Спасибо»: 5 раз
Поблагодарили: 1 раз в 1 постах
Как можно вручную установить криптопро csp?
Я скачал архив

написал скрипт для его потрешения

#! /bin/sh
for i in *.rpm; do
rpmextract.sh $i
rm $i
done

for i in *.tar.gz; do
tar xf $i
rm $i
done

Получил кучу папок с содержимым etc lib64 и тд

Распихал это по файловой системе а оно все равно не работает
хотелось бы узнать какие из rpm нужно ставить при минимальной установке(чтобы были просто доступны алгоритмы подписи и можно подписывать например xml)
из этих?

./lsb-cprocsp-rdr-sobol-64-4.0.9944-5.x86_64.rpm
./cprocsp-ipsec-devel-4.0.9944-5.noarch.rpm
./cprocsp-cpopenssl-base-4.0.9944-5.noarch.rpm
./cprocsp-drv-devel-4.0.9944-5.noarch.rpm
./cprocsp-cpopenssl-gost-64-4.0.9944-5.x86_64.rpm
./cprocsp-xer2print-4.0.9944-5.noarch.rpm
./cprocsp-rdr-rutoken-64-4.0.9944-5.x86_64.rpm
./cprocsp-cpopenssl-devel-4.0.9944-5.noarch.rpm
./lsb-cprocsp-devel-4.0.9944-5.noarch.rpm
./lsb-cprocsp-pkcs11-64-4.0.9944-5.x86_64.rpm
./cprocsp-cpopenssl-64-4.0.9944-5.x86_64.rpm
./cprocsp-rdr-pcsc-64-4.0.9944-5.x86_64.rpm
./cprocsp-rdr-gui-64-4.0.9944-5.x86_64.rpm
./cprocsp-rdr-inpaspot-64-4.0.9944-5.x86_64.rpm
./cprocsp-curl-64-4.0.9944-5.x86_64.rpm
./cprocsp-ipsec-esp-64-4.0.9944-5.src.rpm
./lsb-cprocsp-rdr-accord-64-4.0.9944-5.x86_64.rpm
./lsb-cprocsp-kc2-64-4.0.9944-5.x86_64.rpm
./accord_random-1-0.src.rpm
./cprocsp-rdr-emv-64-4.0.9944-5.x86_64.rpm
./cprocsp-rdr-esmart-64-4.0.9944-5.x86_64.rpm
./cprocsp-rdr-novacard-64-4.0.9944-5.x86_64.rpm
./ifd-rutokens-1.0.1-1.x86_64.rpm
./cprocsp-ipsec-genpsk-64-4.0.9944-5.x86_64.rpm
./cprocsp-drv-64-4.0.9944-5.src.rpm
./cprocsp-rsa-64-4.0.9944-5.x86_64.rpm
./cprocsp-compat-altlinux-64-1.0.0-1.noarch.rpm
./lsb-cprocsp-rdr-maxim-64-4.0.9944-5.x86_64.rpm
./cprocsp-stunnel-64-4.0.9944-5.x86_64.rpm
./lsb-cprocsp-rdr-64-4.0.9944-5.x86_64.rpm
./cprocsp-rdr-jacarta-64-3.6.408.683-4.x86_64.rpm
./cprocsp-ipsec-ike-64-4.0.9944-5.x86_64.rpm
./lsb-cprocsp-capilite-64-4.0.9944-5.x86_64.rpm
./sobol-1-7.src.rpm
./cprocsp-rdr-gui-gtk-64-4.0.9944-5.x86_64.rpm
./lsb-cprocsp-base-4.0.9944-5.noarch.rpm
./cprocsp-rdr-mskey-64-4.0.9944-5.x86_64.rpm
./cprocsp-rdr-rosan-64-4.0.9944-5.x86_64.rpm
./lsb-cprocsp-kc1-64-4.0.9944-5.x86_64.rpm
./lsb-cprocsp-ca-certs-4.0.9944-5.noarch.rpm

Отредактировано пользователем 30 ноября 2018 г. 8:55:44(UTC)  | Причина: Не указана

RSS Лента  Atom Лента
Пользователи, просматривающие эту тему
Быстрый переход  
Вы не можете создавать новые темы в этом форуме.
Вы не можете отвечать в этом форуме.
Вы не можете удалять Ваши сообщения в этом форуме.
Вы не можете редактировать Ваши сообщения в этом форуме.
Вы не можете создавать опросы в этом форуме.
Вы не можете голосовать в этом форуме.