logo Обзор КриптоПро NGate для защищённого доступа к корпоративным ресурсам
Добро пожаловать, Гость! Чтобы использовать все возможности Вход или Регистрация.

Уведомление

Icon
Error

9 Страницы«<6789>
Опции
К последнему сообщению К первому непрочитанному
Offline viroot  
#141 Оставлено : 4 марта 2019 г. 14:49:44(UTC)
viroot

Статус: Новичок

Группы: Участники
Зарегистрирован: 04.03.2019(UTC)
Сообщений: 2
Мужчина
Российская Федерация

Сказал «Спасибо»: 10 раз
IFC 3.0.0.0 Криптопро 4.0.9944 гост 2001, гост 2012. Контейнеры FLASH. Текущий конфиг IFC


Видит и сертификаты 2001 гост, и 2012. При этом по 2001 входит в ЕСИА, 2012 возвращает на страницу авторизации.

выхлон 2001



выхлоп 2012



IFC 3.0.6.0 не удалось заставить работать. Либо не видит сертификатов, либо пишет плагин не установлен. Ни по инструкции Астры, ни по инструкции Альт.Brick wall

Отредактировано пользователем 4 марта 2019 г. 14:52:11(UTC)  | Причина: Не указана

Offline Lirein  
#142 Оставлено : 4 марта 2019 г. 15:11:24(UTC)
Lirein

Статус: Активный участник

Группы: Участники
Зарегистрирован: 18.09.2015(UTC)
Сообщений: 77
Мужчина
Российская Федерация
Откуда: На работе

Сказал «Спасибо»: 17 раз
Поблагодарили: 48 раз в 37 постах
Автор: viroot Перейти к цитате
IFC 3.0.0.0 Криптопро 4.0.9944 гост 2001, гост 2012. Контейнеры FLASH. Текущий конфиг IFC


Видит и сертификаты 2001 гост, и 2012. При этом по 2001 входит в ЕСИА, 2012 возвращает на страницу авторизации.

выхлон 2001



выхлоп 2012



IFC 3.0.6.0 не удалось заставить работать. Либо не видит сертификатов, либо пишет плагин не установлен. Ни по инструкции Астры, ни по инструкции Альт.Brick wall


Добрый день. Предыдушие ребята тоже мучились, работает с КриптоПро 4.0 R4 и IFC Plugin 3.0.6.0, конфиг

https://www.cryptopro.ru...&m=100645#post100645
--- Эльфиек на всех не хватает...
*** А всё таки, она вертится!
thanks 2 пользователей поблагодарили Lirein за этот пост.
viroot оставлено 04.03.2019(UTC), aozimkov оставлено 06.03.2019(UTC)
Offline viroot  
#143 Оставлено : 4 марта 2019 г. 15:32:35(UTC)
viroot

Статус: Новичок

Группы: Участники
Зарегистрирован: 04.03.2019(UTC)
Сообщений: 2
Мужчина
Российская Федерация

Сказал «Спасибо»: 10 раз
Добрый день. Предыдушие ребята тоже мучились, работает с КриптоПро 4.0 R4 и IFC Plugin 3.0.6.0, конфиг

https://www.cryptopro.ru...&m=100645#post100645


Добрый! Пробовал я Ваш конфиг, пишет плагин не установлен! И все, хоть тресни) Я, вообще, не спец, но IFC же сам не занимается подписыванием? Он обращается к прослойке (плагину или как это назвать?) pkcs11? Brick wall

Отредактировано пользователем 4 марта 2019 г. 15:33:32(UTC)  | Причина: Не указана

Offline Lirein  
#144 Оставлено : 4 марта 2019 г. 15:37:04(UTC)
Lirein

Статус: Активный участник

Группы: Участники
Зарегистрирован: 18.09.2015(UTC)
Сообщений: 77
Мужчина
Российская Федерация
Откуда: На работе

Сказал «Спасибо»: 17 раз
Поблагодарили: 48 раз в 37 постах
Автор: viroot Перейти к цитате
Добрый день. Предыдушие ребята тоже мучились, работает с КриптоПро 4.0 R4 и IFC Plugin 3.0.6.0, конфиг

https://www.cryptopro.ru...&m=100645#post100645


Добрый! Пробовал я Ваш конфиг, пишет плагин не установлен! И все, хоть тресни) Я, вообще, не спец, но IFC же сам не занимается подписыванием? Он обращается к прослойке (плагину или как это назвать?) pkcs11? Brick wall


Да, вы правы, IFC обращается к pkcs11 библиотеке работающей, как правило, с pkcs15 токенами. В нашем случае это контейнер криптопровадйера КриптоПро, но может быть и аппаратный ключ защиты (Рутокен ЭЦП) или любой подходящий контейнер с поддержкой ГОСТ. Подписание и шифрование происходит внутри контейнера (средствами аппаратного ключа или средствами криптопровайдера).

Выхлоп лога приложить можете? Или напишите мне в телегу в личку, помогу решить ваш вопрос.
--- Эльфиек на всех не хватает...
*** А всё таки, она вертится!
thanks 2 пользователей поблагодарили Lirein за этот пост.
viroot оставлено 04.03.2019(UTC), aozimkov оставлено 06.03.2019(UTC)
Offline Apster  
#145 Оставлено : 6 марта 2019 г. 11:20:25(UTC)
Apster

Статус: Новичок

Группы: Участники
Зарегистрирован: 06.03.2019(UTC)
Сообщений: 3
Российская Федерация

Сказал(а) «Спасибо»: 1 раз
Поблагодарили: 1 раз в 1 постах
Автор: viroot Перейти к цитате
Добрый день. Предыдушие ребята тоже мучились, работает с КриптоПро 4.0 R4 и IFC Plugin 3.0.6.0, конфиг



Добрый день. КриптоПро 4.0 R4 и IFC Plugin 3.0.6.0 заработали только с контейнерами на флешке, причем как ГОСТ 2001, так и ГОСТ 2012. На Rutoken S не желали от слова совсем на госуслуги заходить. То есть запрашивался один раз пароль и потом кидало обратно на экран входа по ЭЦП.
Offline Lirein  
#146 Оставлено : 6 марта 2019 г. 11:23:46(UTC)
Lirein

Статус: Активный участник

Группы: Участники
Зарегистрирован: 18.09.2015(UTC)
Сообщений: 77
Мужчина
Российская Федерация
Откуда: На работе

Сказал «Спасибо»: 17 раз
Поблагодарили: 48 раз в 37 постах
Автор: Apster Перейти к цитате
Автор: viroot Перейти к цитате
Добрый день. Предыдушие ребята тоже мучились, работает с КриптоПро 4.0 R4 и IFC Plugin 3.0.6.0, конфиг



Добрый день. КриптоПро 4.0 R4 и IFC Plugin 3.0.6.0 заработали только с контейнерами на флешке, причем как ГОСТ 2001, так и ГОСТ 2012. На Rutoken S не желали от слова совсем на госуслуги заходить. То есть запрашивался один раз пароль и потом кидало обратно на экран входа по ЭЦП.


Добрый день. Для Рутокен-S нужно устанавливать драйвер, идёт в комплекте с КриптоПро: ifd-rutokens_1.0.1_amd64. Кроме него в системе должен быть установлен демон pcscd обеспечивающий работу со смарт-картами.
Если драйвер уcтановлен, обязательно проверьте что верно указан тип провайдера, для ГОСТ 2001 должен быть 75, для ГОСТ2012 - соответственно 80. При установке с токена можно указать через ключ -provtype 75 или -provtype 80.

Отредактировано пользователем 6 марта 2019 г. 11:26:24(UTC)  | Причина: Комменатий - тип криптопровайдера

--- Эльфиек на всех не хватает...
*** А всё таки, она вертится!
thanks 1 пользователь поблагодарил Lirein за этот пост.
aozimkov оставлено 06.03.2019(UTC)
Offline Apster  
#147 Оставлено : 6 марта 2019 г. 12:05:22(UTC)
Apster

Статус: Новичок

Группы: Участники
Зарегистрирован: 06.03.2019(UTC)
Сообщений: 3
Российская Федерация

Сказал(а) «Спасибо»: 1 раз
Поблагодарили: 1 раз в 1 постах
Автор: Lirein Перейти к цитате


Добрый день. Для Рутокен-S нужно устанавливать драйвер, идёт в комплекте с КриптоПро: ifd-rutokens_1.0.1_amd64. Кроме него в системе должен быть установлен демон pcscd обеспечивающий работу со смарт-картами.
Если драйвер уcтановлен, обязательно проверьте что верно указан тип провайдера, для ГОСТ 2001 должен быть 75, для ГОСТ2012 - соответственно 80. При установке с токена можно указать через ключ -provtype 75 или -provtype 80.


Драйвер установлен и сертификаты видны, НО при попытке использовать такие пары в логе ошибка подписания... Правильно ли я понимаю, что при установки сертификата в хранилище указать тип провайдера


engine.log:

Offline Lirein  
#148 Оставлено : 6 марта 2019 г. 12:12:10(UTC)
Lirein

Статус: Активный участник

Группы: Участники
Зарегистрирован: 18.09.2015(UTC)
Сообщений: 77
Мужчина
Российская Федерация
Откуда: На работе

Сказал «Спасибо»: 17 раз
Поблагодарили: 48 раз в 37 постах
В логе видно что у вас не находит закрытый ключ. Возможно потому что у сертификата указан тип провайдера
Crypto-Pro GOST R 34.10-2012 KC2 CSP, а должно быть Crypto-Pro GOST R 34.10-2012 KC1 CSP
Попробуйте переустановить CryptoPro установкой именно KC1, KC2 нужна для служб удостоверяющего центра.
Посмотреть список доступных провайдеров для ГОСТ 2012 можно:
/opt/cprocsp/sbin/amd64/cpconfig -defprov -view -provtype 80
--- Эльфиек на всех не хватает...
*** А всё таки, она вертится!
thanks 2 пользователей поблагодарили Lirein за этот пост.
Apster оставлено 06.03.2019(UTC), aozimkov оставлено 06.03.2019(UTC)
Offline Apster  
#149 Оставлено : 6 марта 2019 г. 13:47:56(UTC)
Apster

Статус: Новичок

Группы: Участники
Зарегистрирован: 06.03.2019(UTC)
Сообщений: 3
Российская Федерация

Сказал(а) «Спасибо»: 1 раз
Поблагодарили: 1 раз в 1 постах
Автор: Lirein Перейти к цитате
В логе видно что у вас не находит закрытый ключ. Возможно потому что у сертификата указан тип провайдера
Crypto-Pro GOST R 34.10-2012 KC2 CSP, а должно быть Crypto-Pro GOST R 34.10-2012 KC1 CSP
Попробуйте переустановить CryptoPro установкой именно KC1, KC2 нужна для служб удостоверяющего центра.
Посмотреть список доступных провайдеров для ГОСТ 2012 можно:
/opt/cprocsp/sbin/amd64/cpconfig -defprov -view -provtype 80


Переустановил. Сначала не завелось, потом поставил еще раз дрова рутокен s с сайта и все прошло успешно и с ГОСТ 2001 и с ГОСТ 2012.
thanks 1 пользователь поблагодарил Apster за этот пост.
Lirein оставлено 06.03.2019(UTC)
Offline aozimkov  
#150 Оставлено : 6 марта 2019 г. 13:56:45(UTC)
aozimkov

Статус: Новичок

Группы: Участники
Зарегистрирован: 06.03.2019(UTC)
Сообщений: 9
Российская Федерация
Откуда: Московская область

Сказал(а) «Спасибо»: 18 раз
Поблагодарили: 2 раз в 2 постах
Всем привет!

Помогите пожалуйста, тоже проблема с ключами
Linux 18.04.2 LTS
Rutoken 2.0 ЭЦП с контейнером крипто про на борту

Вооружившись несколькими мануалами, произвел настройку системы и браузеров,

результат проверка на https://www.cryptopro.ru...des/demopage/simple.html проходит успешно
rts-tender - тоже увидел подпись

А вот с gosuslugi.ru и nalog.ru - беда, оба пишут что на носителе ЭЦП сертификатов не найдено

Отдельно поставил Trusted eSign и что странно - тоже не видит сертификатов

при этом $certmgr -list показывает сертификат со всеми моими данными

Подскажите пожалуйста - куда копать?

Заранее большое спасибо


UPD:
Сейчас еще решил проверить сертификат, который ушел на rts-tender

Скачал из заявления, проверил с помощью https://www.justsign.me/...ycpca/VerifyCertificate/

Получил:

Цитата:
Название документа certificat.cer
Результат проверки
Сертификат не действителен

Дополнительная информация
Цепочка сертификатов обработана, но обработка прервана на корневом сертификате, у которого отсутствует отношение доверия с поставщиком доверия.


Получается проблема с настройкой сертификатов все-таки?


UPD 2:

dpkg


Знаю, что пару лишних пакетов стоит(KC2, stunnel итп), потом уже ставил, пока разбирался

UPD3:

$ tail /var/log/ifc/engine_logs/engine.log

Отредактировано пользователем 6 марта 2019 г. 14:21:32(UTC)  | Причина: upd

Offline Lirein  
#151 Оставлено : 6 марта 2019 г. 14:24:32(UTC)
Lirein

Статус: Активный участник

Группы: Участники
Зарегистрирован: 18.09.2015(UTC)
Сообщений: 77
Мужчина
Российская Федерация
Откуда: На работе

Сказал «Спасибо»: 17 раз
Поблагодарили: 48 раз в 37 постах
У вас модуль libcppkcs11 не загружается. Он в /etc/ifc.cfg указан?
https://lkul.nalog.ru - открывается через Хромиум-Гост.
--- Эльфиек на всех не хватает...
*** А всё таки, она вертится!
thanks 1 пользователь поблагодарил Lirein за этот пост.
aozimkov оставлено 06.03.2019(UTC)
Offline aozimkov  
#152 Оставлено : 6 марта 2019 г. 17:20:30(UTC)
aozimkov

Статус: Новичок

Группы: Участники
Зарегистрирован: 06.03.2019(UTC)
Сообщений: 9
Российская Федерация
Откуда: Московская область

Сказал(а) «Спасибо»: 18 раз
Поблагодарили: 2 раз в 2 постах
Автор: Lirein Перейти к цитате
У вас модуль libcppkcs11 не загружается. Он в /etc/ifc.cfg указан?
https://lkul.nalog.ru - открывается через Хромиум-Гост.


Огромное человеческое спасибо за помощь, госуслуги и налог работают!

Из важного, вдруг кто-то будет искать:

- ifc.cfg - обязательно поменять - эта магия работает: https://www.cryptopro.ru...&m=100645#post100645

- для nalog.ru только chromium_gost ( скачать можно здесь: https://github.com/deemru/chromium-gost/releases )
если все должно работать, но что-то не так, попробуйте перейти по прямой ссылке https://lkipgost.nalog.ru/lk должен появится диалог выбора сертификата

- для простой работы с подписями нужен только lsb-cprocsp-kc1-64 kc2- не нужен, если при удалении kc2 что-то перестало работать, может помочь переустановка lsb-cprocsp-kc1-64

- создать контейнер с паролем можно так:
/opt/cprocsp/bin/amd64/csptest -keycopy -contsrc 'имя_контейнера_например\\.\Aktiv Rutoken ECP 00 00\ххххх' -contdest '\\.\HDIMAGE\example' -pindest пароль

- после установить созданный с паролем контейнер для дальнейшего использования: /opt/cprocsp/bin/amd64/certmgr -inst -store uMy -cont '\\.\HDIMAGE\example'

затем можно проверить /opt/cprocsp/bin/amd64/certmgr -list

В выводе обратить внимание на
PrivateKey Link : Yes
Container : HDIMAGE\\example.000\CCAB

работает, ура! Boo hoo!


Lirein, Большое спасибо еще раз! :)
thanks 1 пользователь поблагодарил aozimkov за этот пост.
Lirein оставлено 06.03.2019(UTC)
Offline aozimkov  
#153 Оставлено : 8 марта 2019 г. 11:18:55(UTC)
aozimkov

Статус: Новичок

Группы: Участники
Зарегистрирован: 06.03.2019(UTC)
Сообщений: 9
Российская Федерация
Откуда: Московская область

Сказал(а) «Спасибо»: 18 раз
Поблагодарили: 2 раз в 2 постах
UPD: После успешной установки CryptoPro 4 и настройки ключа Rutoken 2.0 ЭЦП на Ubuntu 18.04 столкнулся с небольшой проблемой, вдруг кому пригодится

При использовании ssh в консоли появилась ошибка:

ssh: /opt/cprocsp/cp-openssl/lib/amd64/libcrypto.so.1.0.0: no version information available (required by ssh)
ssh: /opt/cprocsp/cp-openssl/lib/amd64/libcrypto.so.1.0.0: no version information available (required by ssh)


Проблема заключается в том, что openssl в Ubuntu имеет небольшие отличия от сторонних неубунту-версий
поэтому, когда с другими приложениями устанавливаются openssl-библиотеки в убунту возникает ошибка проверки версии

Нашел следующее решение:

посмотреть расположение стандартных библиотек можно командой:
$ ldd /usr/bin/openssl

можно удалить (или переименовать, чтобы на всякий случай осталась) версию библиотеки поставляемую с CryptoPro и заменить ее на стандартную:

$ sudo mv /opt/cprocsp/cp-openssl/lib/amd64/libcrypto.so.1.0.0 /opt/cprocsp/cp-openssl/lib/amd64/libcrypto.so.1.0.0_bak
$ sudo cp /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 /opt/cprocsp/cp-openssl/lib/amd64/

После этого консоль перестанет показывать ошибку. Работоспособность криптопро проверил - неполадок не обнаружил


Это не правильный путь, снова спасибо Lirein за подсказку :)
Чуть позже проверю и сделаю апдейт с правильным способом

UPD:
Ошибка устраняется удалением пакетов:
cprocsp-cpopenssl-64
cprocsp-cpopenssl-base
cprocsp-cpopenssl-gost-64

Отредактировано пользователем 9 марта 2019 г. 18:11:02(UTC)  | Причина: add right solution

Offline sasha_86  
#154 Оставлено : 13 марта 2019 г. 9:17:01(UTC)
sasha_86

Статус: Новичок

Группы: Участники
Зарегистрирован: 13.03.2019(UTC)
Сообщений: 5

Подскажите как исправить такую ошибку и с чем она связана Error(0x2). Cannot open file
at /dailybuildsbranches/CSP_4_0/CSPbuild/CSP/src/certmgr/certmgr.cpp:3494.Выдает при установки корневого сертификата /opt/cprocsp/bin/amd64/certmgr -inst -store mroot -file 'Домашний/Загрузки/2.cer' -store uRoot

Offline aozimkov  
#155 Оставлено : 13 марта 2019 г. 9:48:20(UTC)
aozimkov

Статус: Новичок

Группы: Участники
Зарегистрирован: 06.03.2019(UTC)
Сообщений: 9
Российская Федерация
Откуда: Московская область

Сказал(а) «Спасибо»: 18 раз
Поблагодарили: 2 раз в 2 постах
Автор: sasha_86 Перейти к цитате
Подскажите как исправить такую ошибку и с чем она связана Error(0x2). Cannot open file
at /dailybuildsbranches/CSP_4_0/CSPbuild/CSP/src/certmgr/certmgr.cpp:3494.Выдает при установки корневого сертификата /opt/cprocsp/bin/amd64/certmgr -inst -store mroot -file 'Домашний/Загрузки/2.cer' -store uRoot



Если я не ошибаюсь, вам не нужно указывать -store дважды, т.е. команда должна выглядеть вроде
/opt/cprocsp/bin/amd64/certmgr -inst -store mroot -file 'Домашний/Загрузки/2.cer'

1. Уточните на всякий случай что вы находитесь в правильной папке, можно сделать это с помощью команды pwd

Вывод должен показать адрес до папки в которой находится папка Домашний, например /home/user/
Это нужно, чтобы точно убедится что вы устанавливаете ключ из правильной папки.

2. Установка сертификата производится с root-правами, т.е. если убунту, то попробуйте
sudo /opt/cprocsp/bin/amd64/certmgr -inst -store mroot -file 'Домашний/Загрузки/2.cer'

Отредактировано пользователем 13 марта 2019 г. 9:54:37(UTC)  | Причина: fix

Offline sasha_86  
#156 Оставлено : 13 марта 2019 г. 10:55:56(UTC)
sasha_86

Статус: Новичок

Группы: Участники
Зарегистрирован: 13.03.2019(UTC)
Сообщений: 5

Нет,также выдает ошибку
user@astra:~/Загрузки/linux-amd64_deb$ sudo /opt/cprocsp/bin/amd64/certmgr -inst -store mroot -file 2.cer
Certmgr 1.1 (c) "Crypto-Pro", 2007-2018.
program for managing certificates, CRLs and stores

Error(0x2). Cannot open file
at /dailybuildsbranches/CSP_4_0/CSPbuild/CSP/src/certmgr/certmgr.cpp:3494

The system cannot find the file specified.
[ErrorCode: 0x00000002]
Offline Lirein  
#157 Оставлено : 13 марта 2019 г. 11:15:25(UTC)
Lirein

Статус: Активный участник

Группы: Участники
Зарегистрирован: 18.09.2015(UTC)
Сообщений: 77
Мужчина
Российская Федерация
Откуда: На работе

Сказал «Спасибо»: 17 раз
Поблагодарили: 48 раз в 37 постах
Автор: sasha_86 Перейти к цитате
Нет,также выдает ошибку
user@astra:~/Загрузки/linux-amd64_deb$ sudo /opt/cprocsp/bin/amd64/certmgr -inst -store mroot -file 2.cer
Certmgr 1.1 (c) "Crypto-Pro", 2007-2018.
program for managing certificates, CRLs and stores

Error(0x2). Cannot open file
at /dailybuildsbranches/CSP_4_0/CSPbuild/CSP/src/certmgr/certmgr.cpp:3494

The system cannot find the file specified.
[ErrorCode: 0x00000002]


Добрый день. Первый раз вы указаывали путь в Загрузки/2.cer - сейчас в Загрузки/linux-amd64_deb/2.cer
Где таки фактически лежит файл?

Наберите вот так:
Код:
sudo /opt/cprocsp/bin/amd64/certmgr -inst -store mroot -file ~/Загрузки/2.cer
--- Эльфиек на всех не хватает...
*** А всё таки, она вертится!
thanks 1 пользователь поблагодарил Lirein за этот пост.
aozimkov оставлено 13.03.2019(UTC)
Offline aozimkov  
#158 Оставлено : 13 марта 2019 г. 11:22:37(UTC)
aozimkov

Статус: Новичок

Группы: Участники
Зарегистрирован: 06.03.2019(UTC)
Сообщений: 9
Российская Федерация
Откуда: Московская область

Сказал(а) «Спасибо»: 18 раз
Поблагодарили: 2 раз в 2 постах
Автор: sasha_86 Перейти к цитате
Нет,также выдает ошибку
user@astra:~/Загрузки/linux-amd64_deb$ sudo /opt/cprocsp/bin/amd64/certmgr -inst -store mroot -file 2.cer
Certmgr 1.1 (c) "Crypto-Pro", 2007-2018.
program for managing certificates, CRLs and stores

Error(0x2). Cannot open file
at /dailybuildsbranches/CSP_4_0/CSPbuild/CSP/src/certmgr/certmgr.cpp:3494

The system cannot find the file specified.
[ErrorCode: 0x00000002]


сделайте пожалуйста:

Код:
cd ~/Загрузки/linux-amd64_deb
ls


UPD: не увидел сообщение Lirein :)
Да проблема в том, что вы вероятно вызываете файл 2.cer из директории, в которой его нет, содержимое директории можно посмотреть командой ls

Отредактировано пользователем 13 марта 2019 г. 11:24:43(UTC)  | Причина: UPD

Offline sasha_86  
#159 Оставлено : 13 марта 2019 г. 12:59:16(UTC)
sasha_86

Статус: Новичок

Группы: Участники
Зарегистрирован: 13.03.2019(UTC)
Сообщений: 5

благодарю!вышло именно так,устанавливали от туда где не было серта,но парадокс в том,что прекрасно понимал что надо указывать ту папку где лежит серт,но не получалось...Think
Offline sasha_86  
#160 Оставлено : 20 марта 2019 г. 8:44:18(UTC)
sasha_86

Статус: Новичок

Группы: Участники
Зарегистрирован: 13.03.2019(UTC)
Сообщений: 5

Помогите с этим плагином,что только не делал пишет "нет действующих сертификатов".Я в ifc.cfg менял конфигурацию,то плагин вылетает,то сертификата нет.Кто разобрался с этим подскажите как сделать.
RSS Лента  Atom Лента
Пользователи, просматривающие эту тему
9 Страницы«<6789>
Быстрый переход  
Вы не можете создавать новые темы в этом форуме.
Вы не можете отвечать в этом форуме.
Вы не можете удалять Ваши сообщения в этом форуме.
Вы не можете редактировать Ваши сообщения в этом форуме.
Вы не можете создавать опросы в этом форуме.
Вы не можете голосовать в этом форуме.