logo Обзор КриптоПро NGate для защищённого доступа к корпоративным ресурсам
Добро пожаловать, Гость! Чтобы использовать все возможности Вход или Регистрация.

Уведомление

Icon
Error

Опции
К последнему сообщению К первому непрочитанному
Offline nickm  
#1 Оставлено : 31 мая 2016 г. 7:24:13(UTC)
nickm

Статус: Активный участник

Группы: Участники
Зарегистрирован: 31.05.2016(UTC)
Сообщений: 150

Сказал(а) «Спасибо»: 17 раз
Поблагодарили: 23 раз в 23 постах
Здравствуйте.

Столкнулся с проблемой из сабжа. Может подскажет как разгребсти этот случай?
Проблема только в плагине. Сам КриптоПро работает, токен считывает, сертификат экспортирует и пр.
С установкой этих же компонентов под Ubuntu проблем не возникало.

Код:
# ls -l
итого 14208
-rw------- 1 user user 12522102 мар  4 19:12 cprocsp-pki-2.0.0-ia32-cades.rpm
-rw------- 1 user user   724180 мар  4 19:12 cprocsp-pki-2.0.0-ia32-plugin.rpm
-rw------- 1 user user  1297260 мар  3 18:39 lsb-cprocsp-devel-4.0.0-4.noarch.rpm


Код:
# urpmi ./*.rpm
Пакет lsb-cprocsp-devel-4.0.0-4.noarch уже установлен
Некоторые запрошенные пакеты не могут быть установлены:
cprocsp-pki-cades-2.0.0-1.i386 (из-за неудовлетворённости libcapi20.so.4)
cprocsp-pki-plugin-2.0.0-1.i386 (из-за неудовлетворённости libcapi20.so.4)
Продолжить установку? (Y/n) y


Код:
# ldconfig -p | grep libcapi20.so.4
        libcapi20.so.4 (libc6) => /opt/cprocsp/lib/ia32/libcapi20.so.4


Код:
# ls -l /opt/cprocsp/lib/ia32
итого 28104
lrwxrwxrwx 1 root root      18 май 30 20:26 libcapi10.so -> libcapi10.so.4.0.4*
lrwxrwxrwx 1 root root      18 май 30 20:26 libcapi10.so.4 -> libcapi10.so.4.0.4*
-rwxr-xr-x 1 root root   41310 дек 29 01:41 libcapi10.so.4.0.4*
lrwxrwxrwx 1 root root      18 май 30 20:26 libcapi20.so -> libcapi20.so.4.0.4*
lrwxrwxrwx 1 root root      18 май 30 20:26 libcapi20.so.4 -> libcapi20.so.4.0.4*
-rwxr-xr-x 1 root root 6003632 дек 29 01:41 libcapi20.so.4.0.4*
lrwxrwxrwx 1 root root      19 май 30 20:26 libcpalloc.so -> libcpalloc.so.0.0.0*
lrwxrwxrwx 1 root root      19 май 30 20:26 libcpalloc.so.0 -> libcpalloc.so.0.0.0*
-rwxr-xr-x 1 root root    4920 дек 29 01:40 libcpalloc.so.0.0.0*
lrwxrwxrwx 1 root root      18 май 30 20:26 libcpasn1.so -> libcpasn1.so.4.0.4*
lrwxrwxrwx 1 root root      18 май 30 20:26 libcpasn1.so.4 -> libcpasn1.so.4.0.4*
-rwxr-xr-x 1 root root 8477682 дек 29 01:40 libcpasn1.so.4.0.4*
-rw-r--r-- 1 root root  405724 дек 29 01:41 libcpcurl.a
lrwxrwxrwx 1 root root      18 май 30 20:26 libcpcurl.so -> libcpcurl.so.4.2.0*
lrwxrwxrwx 1 root root      18 май 30 20:26 libcpcurl.so.4 -> libcpcurl.so.4.2.0*
-rwxr-xr-x 1 root root  317731 дек 29 01:41 libcpcurl.so.4.2.0*
lrwxrwxrwx 1 root root      17 май 30 20:26 libcpext.so -> libcpext.so.4.0.4*
lrwxrwxrwx 1 root root      17 май 30 20:26 libcpext.so.4 -> libcpext.so.4.0.4*
-rwxr-xr-x 1 root root  428379 дек 29 01:41 libcpext.so.4.0.4*
lrwxrwxrwx 1 root root      17 май 30 20:26 libcplib.so -> libcplib.so.4.0.4*
lrwxrwxrwx 1 root root      17 май 30 20:26 libcplib.so.4 -> libcplib.so.4.0.4*
-rwxr-xr-x 1 root root   75971 дек 29 01:40 libcplib.so.4.0.4*
lrwxrwxrwx 1 root root      16 май 30 20:26 libcpui.so -> libcpui.so.4.0.4*
lrwxrwxrwx 1 root root      16 май 30 20:26 libcpui.so.4 -> libcpui.so.4.0.4*
-rwxr-xr-x 1 root root   15079 дек 29 01:41 libcpui.so.4.0.4*
lrwxrwxrwx 1 root root      15 май 30 20:26 libcsp.so -> libcsp.so.4.0.4*
lrwxrwxrwx 1 root root      15 май 30 20:26 libcsp.so.4 -> libcsp.so.4.0.4*
-rwxr-xr-x 1 root root 1652128 дек 29 01:41 libcsp.so.4.0.4*
lrwxrwxrwx 1 root root      18 май 30 20:26 libenroll.so -> libenroll.so.4.0.4*
lrwxrwxrwx 1 root root      18 май 30 20:26 libenroll.so.4 -> libenroll.so.4.0.4*
-rwxr-xr-x 1 root root  608270 дек 29 01:41 libenroll.so.4.0.4*
lrwxrwxrwx 1 root root      18 май 30 20:27 libfgcpui.so -> libfgcpui.so.4.0.4*
lrwxrwxrwx 1 root root      18 май 30 20:27 libfgcpui.so.4 -> libfgcpui.so.4.0.4*
-rwxr-xr-x 1 root root   12587 дек 29 01:41 libfgcpui.so.4.0.4*
lrwxrwxrwx 1 root root      20 май 30 20:26 libjemalloc.so -> libjemalloc.so.0.0.0*
lrwxrwxrwx 1 root root      20 май 30 20:26 libjemalloc.so.0 -> libjemalloc.so.0.0.0*
-rwxr-xr-x 1 root root  252960 дек 29 01:40 libjemalloc.so.0.0.0*
lrwxrwxrwx 1 root root      19 май 30 20:26 libpkixcmp.so -> libpkixcmp.so.4.0.4*
lrwxrwxrwx 1 root root      19 май 30 20:26 libpkixcmp.so.4 -> libpkixcmp.so.4.0.4*
-rwxr-xr-x 1 root root 9268079 дек 29 01:41 libpkixcmp.so.4.0.4*
lrwxrwxrwx 1 root root      19 май 30 20:26 librdrdsrf.so -> librdrdsrf.so.4.0.4*
lrwxrwxrwx 1 root root      19 май 30 20:26 librdrdsrf.so.4 -> librdrdsrf.so.4.0.4*
-rwxr-xr-x 1 root root   14406 дек 29 01:40 librdrdsrf.so.4.0.4*
lrwxrwxrwx 1 root root      20 май 30 20:26 librdrfat12.so -> librdrfat12.so.4.0.4*
lrwxrwxrwx 1 root root      20 май 30 20:26 librdrfat12.so.4 -> librdrfat12.so.4.0.4*
-rwxr-xr-x 1 root root   38433 дек 29 01:40 librdrfat12.so.4.0.4*
lrwxrwxrwx 1 root root      19 май 30 20:27 librdrpcsc.so -> librdrpcsc.so.4.0.4*
lrwxrwxrwx 1 root root      19 май 30 20:27 librdrpcsc.so.4 -> librdrpcsc.so.4.0.4*
-rwxr-xr-x 1 root root   37329 дек 29 01:41 librdrpcsc.so.4.0.4*
lrwxrwxrwx 1 root root      18 май 30 20:26 librdrrdr.so -> librdrrdr.so.4.0.4*
lrwxrwxrwx 1 root root      18 май 30 20:26 librdrrdr.so.4 -> librdrrdr.so.4.0.4*
-rwxr-xr-x 1 root root   73582 дек 29 01:40 librdrrdr.so.4.0.4*
lrwxrwxrwx 1 root root      18 май 30 20:27 librdrric.so -> librdrric.so.4.0.4*
lrwxrwxrwx 1 root root      18 май 30 20:27 librdrric.so.4 -> librdrric.so.4.0.4*
-rwxr-xr-x 1 root root   31667 дек 29 01:41 librdrric.so.4.0.4*
lrwxrwxrwx 1 root root      31 май 30 20:27 librdrrndmbio_gui_fgtk.so -> librdrrndmbio_gui_fgtk.so.4.0.4*
lrwxrwxrwx 1 root root      31 май 30 20:27 librdrrndmbio_gui_fgtk.so.4 -> librdrrndmbio_gui_fgtk.so.4.0.4*
-rwxr-xr-x 1 root root   11725 дек 29 01:41 librdrrndmbio_gui_fgtk.so.4.0.4*
lrwxrwxrwx 1 root root      26 май 30 20:26 librdrrndmbio_tui.so -> librdrrndmbio_tui.so.4.0.4*
lrwxrwxrwx 1 root root      26 май 30 20:26 librdrrndmbio_tui.so.4 -> librdrrndmbio_tui.so.4.0.4*
-rwxr-xr-x 1 root root   14360 дек 29 01:41 librdrrndmbio_tui.so.4.0.4*
lrwxrwxrwx 1 root root      19 май 30 20:26 librdrrndm.so -> librdrrndm.so.4.0.4*
lrwxrwxrwx 1 root root      19 май 30 20:26 librdrrndm.so.4 -> librdrrndm.so.4.0.4*
-rwxr-xr-x 1 root root   11101 дек 29 01:41 librdrrndm.so.4.0.4*
lrwxrwxrwx 1 root root      22 май 30 20:27 librdrrtsupcp.so -> librdrrtsupcp.so.4.0.4*
lrwxrwxrwx 1 root root      22 май 30 20:27 librdrrtsupcp.so.4 -> librdrrtsupcp.so.4.0.4*
-rwxr-xr-x 1 root root   61148 дек 29 01:41 librdrrtsupcp.so.4.0.4*
lrwxrwxrwx 1 root root      18 май 30 20:26 librdrsup.so -> librdrsup.so.4.0.4*
lrwxrwxrwx 1 root root      18 май 30 20:26 librdrsup.so.4 -> librdrsup.so.4.0.4*
-rwxr-xr-x 1 root root  175675 дек 29 01:40 librdrsup.so.4.0.4*
-rw-r--r-- 1 root root   56962 дек 29 01:41 libsspdrv.a
lrwxrwxrwx 1 root root      15 май 30 20:26 libssp.so -> libssp.so.4.0.4*
lrwxrwxrwx 1 root root      15 май 30 20:26 libssp.so.4 -> libssp.so.4.0.4*
-rwxr-xr-x 1 root root  615870 дек 29 01:41 libssp.so.4.0.4*
lrwxrwxrwx 1 root root      23 май 30 20:26 liburlretrieve.so -> liburlretrieve.so.4.0.4*
lrwxrwxrwx 1 root root      23 май 30 20:26 liburlretrieve.so.4 -> liburlretrieve.so.4.0.4*
-rwxr-xr-x 1 root root   21102 дек 29 01:41 liburlretrieve.so.4.0.4*


Offline cross  
#2 Оставлено : 31 мая 2016 г. 10:33:10(UTC)
Анатолий Беляев

Статус: Сотрудник

Группы: Администраторы, Участники
Зарегистрирован: 24.11.2009(UTC)
Сообщений: 909
Откуда: Crypto-Pro

Сказал(а) «Спасибо»: 3 раз
Поблагодарили: 145 раз в 134 постах
В некоторых версиях криптопровайдера не верно выставлены provides в rpm пакетах. Вы можете установить пакеты плагина с ключем --no-deps.
Техническую поддержку оказываем тут.
Наша база знаний.
Наша страничка в Instagram.
Offline nickm  
#3 Оставлено : 31 мая 2016 г. 10:36:15(UTC)
nickm

Статус: Активный участник

Группы: Участники
Зарегистрирован: 31.05.2016(UTC)
Сообщений: 150

Сказал(а) «Спасибо»: 17 раз
Поблагодарили: 23 раз в 23 постах
Да, с ключем --no-deps ставится, но плагин в firefox не работает - висит и крашится.
Вот и думается Мне, что зависимости следует устранить или куда в другую сторону смотреть?
Offline nickm  
#4 Оставлено : 31 мая 2016 г. 13:22:11(UTC)
nickm

Статус: Активный участник

Группы: Участники
Зарегистрирован: 31.05.2016(UTC)
Сообщений: 150

Сказал(а) «Спасибо»: 17 раз
Поблагодарили: 23 раз в 23 постах
Вопрос решился.
Отписался в теме на форуме РОСЫ.

Циатата:
Вроде как разобрался с установкой. И плагин прогрузился и токен сработал и на портал нужный пробился.
На что следует обратить внимание:

1. В архиве плагина идет отличная по сборке библиотека lsb-cprocsp-devel-4.0.0-4.noarch.rpm. В моем случае в плагине 9709, в CSP - 9680
Поэтому при установке плагина этот момент следует учитывать и ставить с ключем --replacepkgs или сразу подменить пакет при установке CSP, что Я и сделал;

2. Не забыть, что демон смарт-карт автоматом не подымается, поэтому при работе с токеном его запускаем "ручками", а после не забываем включить на запуск
Код:
systemctl enable pcscd



Как решился вопрос:
Удалил КриптоПро и установил в след.последовательности:

Код:
#ls -l
cprocsp-curl-4.0.0-4.i486.rpm           
cprocsp-rdr-gui-gtk-4.0.0-4.i486.rpm    
cprocsp-rdr-pcsc-4.0.0-4.i486.rpm       
cprocsp-rdr-rutoken-4.0.0-4.i486.rpm    
ifd-rutokens_1.0.4_1.i486.rpm           
lsb-cprocsp-base-4.0.0-4.noarch.rpm     
lsb-cprocsp-capilite-4.0.0-4.i486.rpm   
lsb-cprocsp-devel-4.0.0-4.noarch.rpm #этот пакет из архива плагина!    
lsb-cprocsp-kc1-4.0.0-4.i486.rpm        
lsb-cprocsp-rdr-4.0.0-4.i486.rpm   


Код:
#urpmi ./*.rpm


Код:
#ls -l
cprocsp-pki-2.0.0-ia32-cades.rpm 
cprocsp-pki-2.0.0-ia32-plugin.rpm


Код:
#urpmi --allow-nodeps ./*.rpm



остальное все стандартно - экспорт пользовательского сертификата, установка в хранилище. Установка корневого сертификата. Настройка доверенных сайтов.
Offline cross  
#5 Оставлено : 31 мая 2016 г. 13:28:46(UTC)
Анатолий Беляев

Статус: Сотрудник

Группы: Администраторы, Участники
Зарегистрирован: 24.11.2009(UTC)
Сообщений: 909
Откуда: Crypto-Pro

Сказал(а) «Спасибо»: 3 раз
Поблагодарили: 145 раз в 134 постах
Devel пакет не является обязательным для работы плагина, он предназначен именно для разработки.

Если плагин висел и через некоторое время выдавал что не может работать то скорее всего у вас не стоял gui о криптопровайдера и плагин пытался показать сообщение о доступе страницы к сертификатам и ключам в консоль.
Техническую поддержку оказываем тут.
Наша база знаний.
Наша страничка в Instagram.
Offline nickm  
#6 Оставлено : 31 мая 2016 г. 13:36:10(UTC)
nickm

Статус: Активный участник

Группы: Участники
Зарегистрирован: 31.05.2016(UTC)
Сообщений: 150

Сказал(а) «Спасибо»: 17 раз
Поблагодарили: 23 раз в 23 постах
Я и не утверждаю что он обязателен. Но выполняя рекомендуемые команды, такие как установка пакетов из архива, натыкаешься на сообщения уже установленных пакетов, несовместимости и пр.
Кол-во пакетов не изменялось, повторюсь имеется опыт установки под Ubuntu поэтому про cprocsp-rdr-gui-gtk-4.0.0-4.i486.rpm все предельно ясно.
И да, склоняюсь к тому, что решение вопроса последовало именно потому, что установка производилась из *.rpm, а не install.sh и последующей установки недостающих для работы пакетов.
RSS Лента  Atom Лента
Пользователи, просматривающие эту тему
Быстрый переход  
Вы не можете создавать новые темы в этом форуме.
Вы не можете отвечать в этом форуме.
Вы не можете удалять Ваши сообщения в этом форуме.
Вы не можете редактировать Ваши сообщения в этом форуме.
Вы не можете создавать опросы в этом форуме.
Вы не можете голосовать в этом форуме.