Ключевое слово в защите информации
КЛЮЧЕВОЕ СЛОВО
в защите информации
Наши способы организации безопасного удалённого доступа к рабочим местам и корпоративным ресурсам
Добро пожаловать, Гость! Чтобы использовать все возможности Вход или Регистрация.

Уведомление

Icon
Error

Опции
К последнему сообщению К первому непрочитанному
Offline eiglikov  
#1 Оставлено : 19 июля 2012 г. 12:15:18(UTC)
eiglikov

Статус: Новичок

Группы: Участники
Зарегистрирован: 19.07.2012(UTC)
Сообщений: 5

Добрый день!

Подскажите, пожалуйста, как импортировать сертификат с закрытым ключом в реестр с помощью демонстрационной версии КриптоПро CSP 3.6 R2? Сертификат хранится в файле PKCS#12.

Сертификат был взят отсюда http://www.cryptopro.ru/certsrv/

Зачем это нужно: КриптоПро CSP 3.6 R2 используется в 1С:Предприятие 8.2. При попытке подписать файл с помощью, хранящегося в реестре, тестового сертификата КриптоПро УЦ, появляется следующая ошибка:

"Сертификат, связанный с закрытым ключом, указывает на модуль криптографии, отличный от текущего. Сертификат связан с модулем криптографии "Microsoft Enhanced Provider v1.0 с типом 1""

Для устранения этой ошибки необходимо импортировать сертификат с помощью КриптоПро CSP, а не оснастки Сертификаты Windows. Вопрос: Как это сделать?

Спасибо за любую помощь.
Online Андрей Писарев  
#2 Оставлено : 19 июля 2012 г. 12:21:10(UTC)
Андрей *

Статус: Сотрудник

Группы: Участники
Зарегистрирован: 26.07.2011(UTC)
Сообщений: 9,198
Мужчина
Российская Федерация

Сказал «Спасибо»: 336 раз
Поблагодарили: 1329 раз в 1034 постах
eiglikov написал:
Добрый день!

Подскажите, пожалуйста, как импортировать сертификат с закрытым ключом в реестр с помощью демонстрационной версии КриптоПро CSP 3.6 R2? Сертификат хранится в файле PKCS#12.

Сертификат был взят отсюда http://www.cryptopro.ru/certsrv/

Зачем это нужно: КриптоПро CSP 3.6 R2 используется в 1С:Предприятие 8.2. При попытке подписать файл с помощью, хранящегося в реестре, тестового сертификата КриптоПро УЦ, появляется следующая ошибка:

"Сертификат, связанный с закрытым ключом, указывает на модуль криптографии, отличный от текущего. Сертификат связан с модулем криптографии "Microsoft Enhanced Provider v1.0 с типом 1""

Для устранения этой ошибки необходимо импортировать сертификат с помощью КриптоПро CSP, а не оснастки Сертификаты Windows. Вопрос: Как это сделать?

Спасибо за любую помощь.


У вас сертификат не с ГОСТ-алгоритмом, а с RSA...
Необходимо зайти на сайт тестового УЦ http://www.cryptopro.ru/certsrv/ и получить новый сертификат с выбранным криптопровайдером - КриптоПРО
(Crypto-Pro GOST R 34.10-2001 Cryptographic Service Provider)

Отредактировано пользователем 19 июля 2012 г. 12:22:19(UTC)  | Причина: Не указана

Техническую поддержку оказываем тут
Наша база знаний
Offline eiglikov  
#3 Оставлено : 19 июля 2012 г. 12:38:21(UTC)
eiglikov

Статус: Новичок

Группы: Участники
Зарегистрирован: 19.07.2012(UTC)
Сообщений: 5

Андрей * написал:
У вас сертификат не с ГОСТ-алгоритмом, а с RSA...
Необходимо зайти на сайт тестового УЦ http://www.cryptopro.ru/certsrv/ и получить новый сертификат с выбранным криптопровайдером - КриптоПРО
(Crypto-Pro GOST R 34.10-2001 Cryptographic Service Provider)


Спасибо за оперативный ответ!

Использую сертификат ГОСТ.

cert.cer
cert.p12

Отредактировано пользователем 19 июля 2012 г. 12:39:03(UTC)  | Причина: Не указана

Online Андрей Писарев  
#4 Оставлено : 19 июля 2012 г. 12:39:43(UTC)
Андрей *

Статус: Сотрудник

Группы: Участники
Зарегистрирован: 26.07.2011(UTC)
Сообщений: 9,198
Мужчина
Российская Федерация

Сказал «Спасибо»: 336 раз
Поблагодарили: 1329 раз в 1034 постах
eiglikov написал:


Спасибо за оперативный ответ!

Использую сертификат ГОСТ.

cert.cer
cert.p12


Там не ГОСТ, а RSA
Нужно смотреть поле: Открытый ключ

а не поле: Алгоритм подписи - это алгоритм подписи сертификата
т.е. УЦ выпустил по вашему запросу сертификат и подписал его, но сертификат - с алгоритмом открытого ключа - RSA - используется встроенный криптопровайдер от MS

Отредактировано пользователем 19 июля 2012 г. 12:42:39(UTC)  | Причина: Не указана

Техническую поддержку оказываем тут
Наша база знаний
Offline eiglikov  
#5 Оставлено : 20 июля 2012 г. 10:03:42(UTC)
eiglikov

Статус: Новичок

Группы: Участники
Зарегистрирован: 19.07.2012(UTC)
Сообщений: 5

Андрей * написал:
Там не ГОСТ, а RSA
Нужно смотреть поле: Открытый ключ

Спасибо за ответ! Всё получилось! Оказывается Тестовый УЦ выдаёт сертификаты RSA и ГОСТ в зависимости от того, через какой браузер осуществляется запрос. Используя Internet Explorer удалось установить сертификат ГОСТ в реестр Windows. После чего сертификат и КриптоПро CSP можно было использовать в 1С:Предприятие:

Код:
&НаКлиенте
Процедура ПодписатьФайл(Команда)
	МенеджерКриптографии = Новый МенеджерКриптографии("Crypto-Pro GOST R 34.10-2001 Cryptographic Service Provider", "", 75);
	ХранилищеСертификатов = МенеджерКриптографии.ПолучитьХранилищеСертификатов(ТипХранилищаСертификатовКриптографии.ПерсональныеСертификаты);
	МассивСертификатов = ХранилищеСертификатов.ПолучитьВсе();
	Сертификат = МассивСертификатов[0];
	МенеджерКриптографии.ПарольДоступаКЗакрытомуКлючу = "123456";
	МенеджерКриптографии.Подписать("D:\ФайлДляПодписи.txt", "D:\Подпись.txt", Сертификат);
КонецПроцедуры

&НаКлиенте
Процедура ПроверитьПодпись(Команда)
	МенеджерКриптографии = Новый МенеджерКриптографии("Crypto-Pro GOST R 34.10-2001 Cryptographic Service Provider", "", 75);
	МенеджерКриптографии.ПроверитьПодпись("D:\ФайлДляПодписи.txt", "D:\Подпись.txt");
	Сообщить("Подпись верна!");
КонецПроцедуры


Не получилось экспортировать тестовый сертификат с закрытым ключом, из реестра Windows в файл PKCS#12 (*.p12). Подскажите пожалуйста: Как это сделать?

Отредактировано пользователем 20 июля 2012 г. 10:06:01(UTC)  | Причина: Не указана

Online Андрей Писарев  
#6 Оставлено : 20 июля 2012 г. 12:54:08(UTC)
Андрей *

Статус: Сотрудник

Группы: Участники
Зарегистрирован: 26.07.2011(UTC)
Сообщений: 9,198
Мужчина
Российская Федерация

Сказал «Спасибо»: 336 раз
Поблагодарили: 1329 раз в 1034 постах
eiglikov написал:
Андрей * написал:
Там не ГОСТ, а RSA
Нужно смотреть поле: Открытый ключ

Спасибо за ответ! Всё получилось! Оказывается Тестовый УЦ выдаёт сертификаты RSA и ГОСТ в зависимости от того, через какой браузер осуществляется запрос. Используя Internet Explorer удалось установить сертификат ГОСТ в реестр Windows. После чего сертификат и КриптоПро CSP можно было использовать в 1С:Предприятие:

Код:
&НаКлиенте
Процедура ПодписатьФайл(Команда)
	МенеджерКриптографии = Новый МенеджерКриптографии("Crypto-Pro GOST R 34.10-2001 Cryptographic Service Provider", "", 75);
	ХранилищеСертификатов = МенеджерКриптографии.ПолучитьХранилищеСертификатов(ТипХранилищаСертификатовКриптографии.ПерсональныеСертификаты);
	МассивСертификатов = ХранилищеСертификатов.ПолучитьВсе();
	Сертификат = МассивСертификатов[0];
	МенеджерКриптографии.ПарольДоступаКЗакрытомуКлючу = "123456";
	МенеджерКриптографии.Подписать("D:\ФайлДляПодписи.txt", "D:\Подпись.txt", Сертификат);
КонецПроцедуры

&НаКлиенте
Процедура ПроверитьПодпись(Команда)
	МенеджерКриптографии = Новый МенеджерКриптографии("Crypto-Pro GOST R 34.10-2001 Cryptographic Service Provider", "", 75);
	МенеджерКриптографии.ПроверитьПодпись("D:\ФайлДляПодписи.txt", "D:\Подпись.txt");
	Сообщить("Подпись верна!");
КонецПроцедуры


Не получилось экспортировать тестовый сертификат с закрытым ключом, из реестра Windows в файл PKCS#12 (*.p12). Подскажите пожалуйста: Как это сделать?



а зачем в p12?

http://www.lissi-crypto.ru/about/news/2011/12/33/

Техническую поддержку оказываем тут
Наша база знаний
Offline eiglikov  
#7 Оставлено : 23 июля 2012 г. 18:56:10(UTC)
eiglikov

Статус: Новичок

Группы: Участники
Зарегистрирован: 19.07.2012(UTC)
Сообщений: 5

Андрей * написал:


Спасибо за ссылку. Часто удаляю сертификат из реестра. Надоело каждый раз делать запрос с сайта http://www.cryptopro.ru/certsrv/. Решил, что было бы не плохо сохранить сертификат в файл PKCS#12.

Программа http://www.lissi-crypto.ru/about/news/2011/12/33/ экспортирует сертификат, но при попытке импортировать сертификат в реестр выдаёт сообщение "Введенный пароль неправилен". Этот вопрос не важен. Спасибо за помощь. Тему можно закрывать.
RSS Лента  Atom Лента
Пользователи, просматривающие эту тему
Быстрый переход  
Вы не можете создавать новые темы в этом форуме.
Вы не можете отвечать в этом форуме.
Вы не можете удалять Ваши сообщения в этом форуме.
Вы не можете редактировать Ваши сообщения в этом форуме.
Вы не можете создавать опросы в этом форуме.
Вы не можете голосовать в этом форуме.