Ключевое слово в защите информации
КЛЮЧЕВОЕ СЛОВО
в защите информации
Наши способы организации безопасного удалённого доступа к рабочим местам и корпоративным ресурсам
Добро пожаловать, Гость! Чтобы использовать все возможности Вход или Регистрация.

Уведомление

Icon
Error

Опции
К последнему сообщению К первому непрочитанному
Offline tarkhil  
#1 Оставлено : 26 мая 2020 г. 14:50:06(UTC)
tarkhil

Статус: Активный участник

Группы: Участники
Зарегистрирован: 19.12.2014(UTC)
Сообщений: 47
Российская Федерация
Откуда: Москва

Сказал(а) «Спасибо»: 3 раз
Вчера старый криптопро (9944) внезапно начал валиться с коредампами вместо работы, и я попробовал его обновить.

Цитата:
[14:43] office:~/freebsd-amd64-2020 # pkg add -f cpro-capilite-64-4.0.9963_0.tbz
Installing cpro-capilite-64-4.0.9963_0...
pkg: wrong architecture: freebsd:10:x86:64 instead of FreeBSD:12:amd64
`-- Installing cpro-rdr-64-4.0.9963_0...
pkg: wrong architecture: freebsd:10:x86:64 instead of FreeBSD:12:amd64

Failed to install the following 1 package(s): cpro-capilite-64-4.0.9963_0.tbz


Прошу обратить внимание, pkg add -f, который в прошлый раз отлично сработал. Что с этим можно сделать?
Online nickm  
#2 Оставлено : 26 мая 2020 г. 15:07:24(UTC)
nickm

Статус: Активный участник

Группы: Участники
Зарегистрирован: 31.05.2016(UTC)
Сообщений: 170

Сказал(а) «Спасибо»: 23 раз
Поблагодарили: 28 раз в 28 постах
Возможно конечно не по теме - а почему не используете install.sh?
Offline tarkhil  
#3 Оставлено : 26 мая 2020 г. 15:44:43(UTC)
tarkhil

Статус: Активный участник

Группы: Участники
Зарегистрирован: 19.12.2014(UTC)
Сообщений: 47
Российская Федерация
Откуда: Москва

Сказал(а) «Спасибо»: 3 раз
Автор: nickm Перейти к цитате
Возможно конечно не по теме - а почему не используете install.sh?


Он ставит все подряд и, по-моему, что-то из нужного не ставит.

Но эту проблему я понял и обошел, и теперь

Certmgr 1.1 (c) "Crypto-Pro", 2007-2018.
program for managing certificates, CRLs and stores

Failed to acquire context

Provider type not defined.
[ErrorCode: 0x80090017]

а предыдущая версия работала...
Online nickm  
#4 Оставлено : 26 мая 2020 г. 16:21:59(UTC)
nickm

Статус: Активный участник

Группы: Участники
Зарегистрирован: 31.05.2016(UTC)
Сообщений: 170

Сказал(а) «Спасибо»: 23 раз
Поблагодарили: 28 раз в 28 постах
Автор: tarkhil Перейти к цитате
Он ставит все подряд и, по-моему, что-то из нужного не ставит.

Скрипт можно конечно чуть-чуть и поправить, просто там ведь логика для обхода предусмотрена, которую можно и нужно "подсмотреть".


Автор: tarkhil Перейти к цитате
Но эту проблему я понял и обошел, и теперь

Certmgr 1.1 (c) "Crypto-Pro", 2007-2018.
program for managing certificates, CRLs and stores

Failed to acquire context

Provider type not defined.
[ErrorCode: 0x80090017]

а предыдущая версия работала...


Вы просто переустановили один из пакетов, а требуется возможно переустановить весь пакет программ.

Offline tarkhil  
#5 Оставлено : 26 мая 2020 г. 16:52:04(UTC)
tarkhil

Статус: Активный участник

Группы: Участники
Зарегистрирован: 19.12.2014(UTC)
Сообщений: 47
Российская Федерация
Откуда: Москва

Сказал(а) «Спасибо»: 3 раз
Автор: nickm Перейти к цитате
Автор: tarkhil Перейти к цитате
Он ставит все подряд и, по-моему, что-то из нужного не ставит.

Скрипт можно конечно чуть-чуть и поправить, просто там ведь логика для обхода предусмотрена, которую можно и нужно "подсмотреть".


Автор: tarkhil Перейти к цитате
Но эту проблему я понял и обошел, и теперь

Certmgr 1.1 (c) "Crypto-Pro", 2007-2018.
program for managing certificates, CRLs and stores

Failed to acquire context

Provider type not defined.
[ErrorCode: 0x80090017]

а предыдущая версия работала...


Вы просто переустановили один из пакетов, а требуется возможно переустановить весь пакет программ.



Я вроде не первый день админю. Пакеты переустановлены все, какие были. Но идея хорошая, сейчас проверю...

Все.

cpro-base-4.0.9963_0 ?
cpro-capilite-64-4.0.9963_0 ?
cpro-curl-64-4.0.9963_0 ?
cpro-kc1-64-4.0.9963_0 ?
cpro-pkcs11-64-4.0.9963_0 ?
cpro-rdr-64-4.0.9963_0 ?
cpro-rdr-pcsc-64-4.0.9963_0 ?
cpro-rdr-rutoken-64-4.0.9963_0 ?

Но к pcscd обращений нет, я проверял
RSS Лента  Atom Лента
Пользователи, просматривающие эту тему
Быстрый переход  
Вы не можете создавать новые темы в этом форуме.
Вы не можете отвечать в этом форуме.
Вы не можете удалять Ваши сообщения в этом форуме.
Вы не можете редактировать Ваши сообщения в этом форуме.
Вы не можете создавать опросы в этом форуме.
Вы не можете голосовать в этом форуме.