Ключевое слово в защите информации
КЛЮЧЕВОЕ СЛОВО
в защите информации
Получить ГОСТ TLS-сертификат для домена (SSL-сертификат)
Добро пожаловать, Гость! Чтобы использовать все возможности Вход или Регистрация.

Уведомление

Icon
Error

Опции
К последнему сообщению К первому непрочитанному
Offline Riddick-84  
#1 Оставлено : 14 января 2022 г. 19:58:54(UTC)
Riddick-84

Статус: Активный участник

Группы: Участники
Зарегистрирован: 26.11.2018(UTC)
Сообщений: 35
Российская Федерация
Откуда: Рязань

Сказал(а) «Спасибо»: 3 раз
поставил криптопро для линукса
csptest -oid -general
CSP (Type:80) v4.0.9017 KC2 Release Ver:4.0.9944 OS:Linux CPU:AMD64 FastCode:READY:AVX.
CryptAcquireContext succeeded.HCRYPTPROV: 19399171
Total: SYS: 0,000 sec USR: 0,000 sec UTC: 0,010 sec
[ErrorCode: 0x00000000]


поставил cades-linux и плагин
но выдает ошибку при тестировании что не найден криптопро

Расширение загружено
Плагин загружен
КриптоПро CSP не загружен
Версия плагина: 2.0.14458

при тестировании здесь
https://www.cryptopro.ru...ge/cades_bes_sample.html
как решить?
Offline nickm  
#2 Оставлено : 14 января 2022 г. 22:07:13(UTC)
nickm

Статус: Активный участник

Группы: Участники
Зарегистрирован: 31.05.2016(UTC)
Сообщений: 273

Сказал(а) «Спасибо»: 92 раз
Поблагодарили: 51 раз в 47 постах
Вопросов несколько:

Автор: Riddick-84 Перейти к цитате
Ver:4.0.9944

Для чего Вы выбрали и установили данную версию, а не последнюю сертифицированную "КриптоПро CSP 4.0 R4 (сборка 4.0.9963 Abel)"?

Автор: Riddick-84 Перейти к цитате
KC2

С какой целью/ обдуманно ли Вы выбрали именно этот класс защиты информации?





Offline Riddick-84  
#3 Оставлено : 15 января 2022 г. 0:04:18(UTC)
Riddick-84

Статус: Активный участник

Группы: Участники
Зарегистрирован: 26.11.2018(UTC)
Сообщений: 35
Российская Федерация
Откуда: Рязань

Сказал(а) «Спасибо»: 3 раз
Автор: nickm Перейти к цитате
Вопросов несколько:

Автор: Riddick-84 Перейти к цитате
Ver:4.0.9944

Для чего Вы выбрали и установили данную версию, а не последнюю сертифицированную "КриптоПро CSP 4.0 R4 (сборка 4.0.9963 Abel)"?


Автор: Riddick-84 Перейти к цитате
KC2

С какой целью/ обдуманно ли Вы выбрали именно этот класс защиты информации?



эта версия заработала на другой машине с чистой установкой линукса. а вот на моей не заработала. неск раз переставлял криптопро использую эту версию т к такая указана на сайте налоговой

нет выбрал необдуманно эту версию (кс2)

снес криптопро полностью поставил заново
теперь проверка тут проходит в файрфоксе https://cryptopro.ru/sit...ge/cades_bes_sample.html
виден криптопро и проходит подпись. но при авторизации на госуслугах выдает что плагин ен установлен
в чем может быть причина?

Отредактировано пользователем 15 января 2022 г. 2:21:59(UTC)  | Причина: Не указана

Offline nickm  
#4 Оставлено : 15 января 2022 г. 8:44:18(UTC)
nickm

Статус: Активный участник

Группы: Участники
Зарегистрирован: 31.05.2016(UTC)
Сообщений: 273

Сказал(а) «Спасибо»: 92 раз
Поблагодарили: 51 раз в 47 постах
Автор: Riddick-84 Перейти к цитате
виден криптопро и проходит подпись. но при авторизации на госуслугах выдает что плагин ен установлен
в чем может быть причина?


Внимательно читаем и выполняем:


+

Автор: Riddick-84 Перейти к цитате
Автор: Riddick-84 Перейти к цитате
Ver:4.0.9944
эта версия заработала на другой машине с чистой установкой линукса.


Если у Вас имеется лицензия на v4, то Я бы рекомендовал к использованию "КриптоПро CSP 5.0 (сборка 5.0.11455 Fury)".

Отредактировано пользователем 15 января 2022 г. 10:58:40(UTC)  | Причина: Не указана

thanks 2 пользователей поблагодарили nickm за этот пост.
Riddick-84 оставлено 15.01.2022(UTC), Андрей Русев оставлено 15.01.2022(UTC)
Offline Riddick-84  
#5 Оставлено : 15 января 2022 г. 13:14:54(UTC)
Riddick-84

Статус: Активный участник

Группы: Участники
Зарегистрирован: 26.11.2018(UTC)
Сообщений: 35
Российская Федерация
Откуда: Рязань

Сказал(а) «Спасибо»: 3 раз
Автор: nickm Перейти к цитате
Автор: Riddick-84 Перейти к цитате
виден криптопро и проходит подпись. но при авторизации на госуслугах выдает что плагин ен установлен
в чем может быть причина?


Внимательно читаем и выполняем:


+

Автор: Riddick-84 Перейти к цитате
Автор: Riddick-84 Перейти к цитате
Ver:4.0.9944
эта версия заработала на другой машине с чистой установкой линукса.


Если у Вас имеется лицензия на v4, то Я бы рекомендовал к использованию "КриптоПро CSP 5.0 (сборка 5.0.11455 Fury)".


Большое спасибо. заработало по инфе из этой статьи а именно не был установлен плагин для файрфокса https://ds-plugin.gosusl...strib/addon-1.2.8-fx.xpi
Offline Riddick-84  
#6 Оставлено : 15 января 2022 г. 21:34:09(UTC)
Riddick-84

Статус: Активный участник

Группы: Участники
Зарегистрирован: 26.11.2018(UTC)
Сообщений: 35
Российская Федерация
Откуда: Рязань

Сказал(а) «Спасибо»: 3 раз
Автор: Riddick-84 Перейти к цитате
Автор: nickm Перейти к цитате
Автор: Riddick-84 Перейти к цитате
виден криптопро и проходит подпись. но при авторизации на госуслугах выдает что плагин ен установлен
в чем может быть причина?


Внимательно читаем и выполняем:


+

Автор: Riddick-84 Перейти к цитате
Автор: Riddick-84 Перейти к цитате
Ver:4.0.9944
эта версия заработала на другой машине с чистой установкой линукса.


Если у Вас имеется лицензия на v4, то Я бы рекомендовал к использованию "КриптоПро CSP 5.0 (сборка 5.0.11455 Fury)".


Большое спасибо. заработало по инфе из этой статьи а именно не был установлен плагин для файрфокса https://ds-plugin.gosusl...strib/addon-1.2.8-fx.xpi


странно но сайт налоговой не хочет работать с линуксом может кто сталкивался и удалось победить?
в самих госуслугах авторизация проходит
Offline nickm  
#7 Оставлено : 15 января 2022 г. 22:30:07(UTC)
nickm

Статус: Активный участник

Группы: Участники
Зарегистрирован: 31.05.2016(UTC)
Сообщений: 273

Сказал(а) «Спасибо»: 92 раз
Поблагодарили: 51 раз в 47 постах
Автор: Riddick-84 Перейти к цитате
странно но сайт налоговой не хочет работать

Как именно не хочет?
Какие действия Вы пытаетесь выполнить на сайте ФНС?
В каком браузере?

Offline Riddick-84  
#8 Оставлено : 16 января 2022 г. 11:31:20(UTC)
Riddick-84

Статус: Активный участник

Группы: Участники
Зарегистрирован: 26.11.2018(UTC)
Сообщений: 35
Российская Федерация
Откуда: Рязань

Сказал(а) «Спасибо»: 3 раз
Автор: nickm Перейти к цитате
Автор: Riddick-84 Перейти к цитате
странно но сайт налоговой не хочет работать

Как именно не хочет?
Какие действия Вы пытаетесь выполнить на сайте ФНС?
В каком браузере?


для юрлиц пытаюсь выолнить проверку наличия подписи это этап входа на сайт
браузер хромиум гост
подменил юзерагента на эксплорере и ос виндоус выдает ошибку что плагин не установлен.


Установлен программный компонент для работы с электронной подписью с использованием Web-браузера.
Версия плагина: ? / рекомендуемая: не ниже 2.0
Криптопровайдер: ?
Версия криптопровайдера: ? / рекомендуемая: не ниже 4.0.0 или ViPNet

ПРОВЕРКА КОМПОНЕНТА ДЛЯ РАБОТЫ С ЭЛЕКТРОННОЙ ПОДПИСЬЮ
Плагин не установлен.

К сожалению, Вы не сможете воспользоваться сервисом. Устраните причины, указанные выше и повторите попытку подключения.

Offline nickm  
#9 Оставлено : 16 января 2022 г. 12:23:19(UTC)
nickm

Статус: Активный участник

Группы: Участники
Зарегистрирован: 31.05.2016(UTC)
Сообщений: 273

Сказал(а) «Спасибо»: 92 раз
Поблагодарили: 51 раз в 47 постах
Автор: Riddick-84 Перейти к цитате
для юрлиц пытаюсь выполнить проверку наличия подписи это этап входа на сайт

Если Вы всё настроили по инструкции, то проверку проходить не надо, а следует сразу переходить по прямой ссылке в ЛК ЮЛ.
Offline Riddick-84  
#10 Оставлено : 16 января 2022 г. 12:55:17(UTC)
Riddick-84

Статус: Активный участник

Группы: Участники
Зарегистрирован: 26.11.2018(UTC)
Сообщений: 35
Российская Федерация
Откуда: Рязань

Сказал(а) «Спасибо»: 3 раз
Автор: nickm Перейти к цитате
Автор: Riddick-84 Перейти к цитате
для юрлиц пытаюсь выполнить проверку наличия подписи это этап входа на сайт

Если Вы всё настроили по инструкции, то проверку проходить не надо, а следует сразу переходить по прямой ссылке в ЛК ЮЛ.


Спасибо за прямую ссылку. зашел через хромиум гост
в файрфоксе выдало
Secure Connection Failed

An error occurred during a connection to lkul.nalog.ru. Cannot communicate securely with peer: no common encryption algorithm(s).

Error code: SSL_ERROR_NO_CYPHER_OVERLAP

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem.

через файрфокс возможно войти? в госуслуги входит
Offline nickm  
#11 Оставлено : 16 января 2022 г. 13:04:02(UTC)
nickm

Статус: Активный участник

Группы: Участники
Зарегистрирован: 31.05.2016(UTC)
Сообщений: 273

Сказал(а) «Спасибо»: 92 раз
Поблагодарили: 51 раз в 47 постах
Автор: nickm Перейти к цитате
Если Вы всё настроили по инструкции

Автор: Riddick-84 Перейти к цитате
через файрфокс возможно войти?


Инструкция на сайте (подробная инструкция в файле), читаем:
Цитата:
Браузер с поддержкой шифрования защищенных соединений по ГОСТ 34.10-2001, ГОСТ 28147-89, ГОСТ Р 34.11-2012

Отредактировано пользователем 16 января 2022 г. 13:04:40(UTC)  | Причина: Не указана

Offline Riddick-84  
#12 Оставлено : 16 января 2022 г. 21:32:44(UTC)
Riddick-84

Статус: Активный участник

Группы: Участники
Зарегистрирован: 26.11.2018(UTC)
Сообщений: 35
Российская Федерация
Откуда: Рязань

Сказал(а) «Спасибо»: 3 раз
Автор: nickm Перейти к цитате
Автор: nickm Перейти к цитате
Если Вы всё настроили по инструкции

Автор: Riddick-84 Перейти к цитате
через файрфокс возможно войти?


Инструкция на сайте (подробная инструкция в файле), читаем:
Цитата:
Браузер с поддержкой шифрования защищенных соединений по ГОСТ 34.10-2001, ГОСТ 28147-89, ГОСТ Р 34.11-2012

понял, спасибо, файрфокса нет в списке допустимых браузеров

Offline nickm  
#13 Оставлено : 17 января 2022 г. 6:08:30(UTC)
nickm

Статус: Активный участник

Группы: Участники
Зарегистрирован: 31.05.2016(UTC)
Сообщений: 273

Сказал(а) «Спасибо»: 92 раз
Поблагодарили: 51 раз в 47 постах
Автор: Riddick-84 Перейти к цитате
понял, спасибо, файрфокса нет в списке допустимых браузеров

Не в списке дело, а в, повторная цитата:
Цитата:
Браузер с поддержкой шифрования защищенных соединений по ГОСТ 34.10-2001, ГОСТ 28147-89, ГОСТ Р 34.11-2012



Offline two_oceans  
#14 Оставлено : 17 января 2022 г. 6:19:36(UTC)
two_oceans

Статус: Эксперт

Группы: Участники
Зарегистрирован: 05.03.2015(UTC)
Сообщений: 1,429
Российская Федерация
Откуда: Иркутская область

Сказал(а) «Спасибо»: 95 раз
Поблагодарили: 342 раз в 322 постах
Автор: nickm Перейти к цитате
Если Вы всё настроили по инструкции, то проверку проходить не надо.
Коллега, для сведения. Как раз в пятницу пробовал: пройти проверку можно, если замаскировать Хромиум ГОСТ в Яндекс Браузер любым расширением, меняющим User-agent. Сначала пробовал маскировать в ИЕ, но видимо сайт налоговой меняет код поиска плагина в зависимости от браузера и так плагин не нашелся. Максировка в Яндекс, что 20, что 200 версии прошла успешно - как проверка прошла успешно, так и сам вход.
Код:
Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.128 YaBrowser/200.4.0.1458 Yowser/2.5 Safari/537.36
Для Linux
Код:
Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.136 YaBrowser/20.2.5.140.00 Safari/537.36
Правда с маской 200 версии отпала проверка на странице проверки плагина КриптоПро, так что надо такое художество ограничить сайтом налоговой или вводить допустимое значение. Ссылки что использовались для проверки.

Цитата:
через файрфокс возможно войти? в госуслуги входит
Только если перед файерфоксом (либо другим браузером без поддержки) на том же компьютере стоит криптотоннель, например, двойной stunnel - один снимает шифрование гост, другой накладывает поддерживаемое браузером. "На том же компьютере" - это требование безопасности, так как нужно доводить гост-защищенный трафик до компьютера в неизменном виде. В такой схеме еще и потребуется самодельный сертификат сайта, так что среднему пользователю не рекомендуется.

Госуслуги же (пока что) поддерживают как гост шифрование, так и зарубежное - если браузер не поддерживает гост, автоматом выбирается другое шифрование.

Отредактировано пользователем 17 января 2022 г. 6:37:19(UTC)  | Причина: Не указана

RSS Лента  Atom Лента
Пользователи, просматривающие эту тему
Быстрый переход  
Вы не можете создавать новые темы в этом форуме.
Вы не можете отвечать в этом форуме.
Вы не можете удалять Ваши сообщения в этом форуме.
Вы не можете редактировать Ваши сообщения в этом форуме.
Вы не можете создавать опросы в этом форуме.
Вы не можете голосовать в этом форуме.