Ключевое слово в защите информации
КЛЮЧЕВОЕ СЛОВО
в защите информации
Наши способы организации безопасного удалённого доступа к рабочим местам и корпоративным ресурсам
Добро пожаловать, Гость! Чтобы использовать все возможности Вход или Регистрация.

Уведомление

Icon
Error

Опции
К последнему сообщению К первому непрочитанному
Offline Августина  
#1 Оставлено : 17 июля 2020 г. 16:14:33(UTC)
Августина

Статус: Участник

Группы: Участники
Зарегистрирован: 17.07.2020(UTC)
Сообщений: 18
Российская Федерация
Откуда: Москва

Сказал(а) «Спасибо»: 2 раз
Здравствуйте, не получается собрать расширение.
Процесс установки описан ниже.

Для установки смотрела следующие ссылки:

Использовала следующие программные продукты:

Пакеты установлены:
  • boost-devel
  • php-devel
  • libxml2-devel

Код:
php -v
    PHP 7.4.8 (cli) (built: Jul  9 2020 08:57:23) ( NTS )
    Copyright (c) The PHP Group
    Zend Engine v3.4.0, Copyright (c) Zend Technologies
root@dev3 /h# lsb_release -d                                                                                                
    Description:    CentOS Linux release 7.7.1908 (Core)


Код:
wget https://www.php.net/distributions/php-7.4.8.tar.gz
wget https://www.cryptopro.ru/sites/default/files/products/cades/current_release_2_0/cades_linux_amd64.tar.gz
wget https://www.cryptopro.ru/sites/default/files/products/cades/php7_support.patch.zip


вытаскиваю всё из архивов и переношу в папку /root/

Код:
root@dev3 ~/linux-amd64# ./install.sh
    Uninstalling CSP packages...
    CSP packages have been successfully uninstalled
    Installing lsb-cprocsp-base-5.0.11823-6.noarch.rpm ...
    Installing lsb-cprocsp-rdr-64-5.0.11823-6.x86_64.rpm ...
    Installing lsb-cprocsp-kc1-64-5.0.11823-6.x86_64.rpm ...
    Installing lsb-cprocsp-capilite-64-5.0.11823-6.x86_64.rpm ...
    Installing cprocsp-curl-64-5.0.11823-6.x86_64.rpm lsb-cprocsp-ca-certs-5.0.11823-6.noarch.rpm ...
    CSP packages have been successfully install
root@dev3 ~/cades_linux_amd64# rpm -i cprocsp-pki-phpcades-64-2.0.14071-1.amd64.rpm
root@dev3 ~/cades_linux_amd64# rpm -i cprocsp-pki-cades-64-2.0.14071-1.amd64.rpm
    License ****-U0030-****-RRLMF-UU2WK is set
    [ErrorCode: 0x00000000]
    License ****-G0030-****-RRLNE-BTDVV is set
    [ReturnCode: 0x00000000]
root@dev3 ~/cades_linux_amd64# rpm -i lsb-cprocsp-devel-5.0.11823-6.noarch.rpm
root@dev3 ~/linux-amd64# rpm -qa|grep cpro
    lsb-cprocsp-capilite-64-5.0.11823-6.x86_64
    lsb-cprocsp-base-5.0.11823-6.noarch
    lsb-cprocsp-devel-5.0.11823-6.noarch
    lsb-cprocsp-rdr-64-5.0.11823-6.x86_64
    cprocsp-curl-64-5.0.11823-6.x86_64
    lsb-cprocsp-kc1-64-5.0.11823-6.x86_64
    cprocsp-pki-phpcades-64-2.0.14071-1.x86_64
    cprocsp-pki-cades-64-2.0.14071-1.x86_64
    lsb-cprocsp-ca-certs-5.0.11823-6.noarch
root@dev3 /o/c/s/phpcades# vim Makefile.unix прописываю путь до исходников пхп 
root@dev3 /h# unzip php7_support.patch.zip
root@dev3 /h# cp php7_support.patch /opt/cprocsp/src/phpcades
root@dev3 /o/c/s/phpcades# patch -p0 < ./php7_support.patch

Результат работы патча в спойлере, как я понимаю, всё прошло без ошибок

Код:

root@dev3 /o/c/s/phpcades# eval '/opt/cprocsp/src/doxygen/CSP/../setenv.sh --64';
    No compiler specified... trying to guess
    g++ found in the path
    CC="gcc";export CC;
    CXX="g++ ";export CXX;
    LSB_LD=/lib64/ld-lsb-x86-64.so.3;export LSB_LD;
    CSP_DIR=/opt/cprocsp;
    CSP_INCLUDE=/opt/cprocsp/include;
    add_CPPFLAGS="-D_COMPACT -DHAVE_STDINT_H ";
    SIZEOF_VOID_P=8;
    CSP_LIB=/opt/cprocsp/lib/amd64;
    INSTALL=install;
    MODVERSFILE=/opt/cprocsp/include/Module.symvers.amd64;
    CSP_EXTRA_LIBS="-lpthread";
    export CSP_DIR CSP_INCLUDE CSP_LIB CSP_EXTRA_LIBS SIZEOF_VOID_P INSTALL add_ldflags add_CPPFLAGS MODVERSFILE;
root@dev3 /o/c/s/phpcades# make -f Makefile.unix
    g++ -DLINUX  -DUNIX -DHAVE_LIMITS_H   -I/ -I/cpcsp -I/pki -I/pki/atl -I/pki/cppcades -I/pki/cplib -I/root/php-7.4.8/ -I/root/php-7.4.8//main -I/root/php-7.4.8//Zend -I/root/php-7.4.8//TSRM  -DSIZEOF_VOID_P= -fPIC -DPIC -c -o PHPCadesCPSigners.o PHPCadesCPSigners.cpp
    In file included from PHPCadesCPSigners.cpp:1:0:
    stdafx.h:39:28: фатальная ошибка: CSP_WinDef.h: Нет такого файла или каталога
        #include "CSP_WinDef.h"
                                ^
    компиляция прервана.
    make: *** [PHPCadesCPSigners.o] Ошибка 1


Подскажите, пожалуйста, в чем может быть проблема.

Отредактировано пользователем 23 июля 2020 г. 11:56:03(UTC)  | Причина: Не указана

Offline Александр Лавник  
#2 Оставлено : 22 июля 2020 г. 13:49:17(UTC)
Александр Лавник

Статус: Сотрудник

Группы: Участники
Зарегистрирован: 30.06.2016(UTC)
Сообщений: 2,189
Мужчина
Российская Федерация

Сказал «Спасибо»: 33 раз
Поблагодарили: 507 раз в 482 постах
Здравствуйте.

К сожалению, для сборки расширения phpcades версии 2.0.14071 необходимо установить devel-пакет из неопубликованной еще сборки КриптоПро CSP 5.0.

Напишите в ЛС Ваш email, и я вышлю Вам нужный пакет.
Техническую поддержку оказываем тут
Наша база знаний
thanks 1 пользователь поблагодарил Александр Лавник за этот пост.
Августина оставлено 22.07.2020(UTC)
Offline Местный  
#3 Оставлено : 22 июля 2020 г. 17:35:01(UTC)
Местный

Статус: Новичок

Группы: Участники
Зарегистрирован: 22.07.2020(UTC)
Сообщений: 2
Российская Федерация
Откуда: Сочи

Сказал(а) «Спасибо»: 1 раз
Автор: Александр Лавник Перейти к цитате
Здравствуйте.

К сожалению, для сборки расширения phpcades версии 2.0.14071 необходимо установить devel-пакет из неопубликованной еще сборки КриптоПро CSP 5.0.

Напишите в ЛС Ваш email, и я вышлю Вам нужный пакет.



Добрый день, провозюкался целый день. Может выложите на общий обзор файлы, а не будете высылать персонально на email ?

на ubuntu 18
fatal error: asn1/Attribute.h: No such file or directory
#include <asn1/Attribute.h>

Все инструкции твердят вплоть до оф., что нужно распаковать SDK и там файл lsb-cprocsp-devel.deb или .rpm,не важно

Ну нету там таких файлов, нету ....а с крипто про не подходит файл lsb-cprocsp-devel.deb

Уже и 7.2 и 7.3 ставил, удалял устанавливал пакеты sdk....В чем может быть дело?...Все перелопатил уже..CSP 5 (первая самая что сертифицированная) и sdk 2 (пробовал sdk 1.5 без толку)

Код:
root@ruvds-lt45q:/opt/cprocsp/src/phpcades# make -f Makefile.unix
g++ -DLINUX  -DUNIX -DHAVE_LIMITS_H   -DHAVE_STDINT_H -I/opt/cprocsp/include/ -I/opt/cprocsp/include/cpcsp -I/opt/cprocsp/include/pki -I/opt/cprocsp/include/pki/atl -I/opt/cprocsp/include/pki/cppcades -I/opt/cprocsp/include/pki/cplib -I/var/php-7.3.20 -I/var/php-7.3.20/main -I/var/php-7.3.20/Zend -I/var/php-7.3.20/TSRM  -DSIZEOF_VOID_P=8 -fPIC -DPIC -c -o PHPCadesCPSigners.o PHPCadesCPSigners.cpp
In file included from /opt/cprocsp/include/pki/asn1/Extension.h:29:0,
                 from /opt/cprocsp/include/pki/cppcades/CPPCadesCPCRL.h:5,
                 from /opt/cprocsp/include/pki/cppcades/CPPCadesCPStore.h:6,
                 from /opt/cprocsp/include/pki/cppcades/CPPCadesCPCertificate.h:11,
                 from /opt/cprocsp/include/pki/cppcades/CPPCadesCPSigner.h:6,
                 from PHPCadesCPSigner.h:4,
                 from PHPCadesCPSigners.cpp:3:
/opt/cprocsp/include/pki/asn1/Types.h:33:10: fatal error: asn1/Attribute.h: No such file or directory
 #include <asn1/Attribute.h>
          ^~~~~~~~~~~~~~~~~~
compilation terminated.
Makefile.unix:30: recipe for target 'PHPCadesCPSigners.o' failed
make: *** [PHPCadesCPSigners.o] Error 1
root@ruvds-lt45q:/opt/cprocsp/src/phpcades#

Отредактировано пользователем 23 июля 2020 г. 0:41:47(UTC)  | Причина: Не указана

Offline Августина  
#4 Оставлено : 22 июля 2020 г. 18:29:42(UTC)
Августина

Статус: Участник

Группы: Участники
Зарегистрирован: 17.07.2020(UTC)
Сообщений: 18
Российская Федерация
Откуда: Москва

Сказал(а) «Спасибо»: 2 раз
Автор: Александр Лавник Перейти к цитате
Здравствуйте.

К сожалению, для сборки расширения phpcades версии 2.0.14071 необходимо установить devel-пакет из неопубликованной еще сборки КриптоПро CSP 5.0.

Напишите в ЛС Ваш email, и я вышлю Вам нужный пакет.


Поставила всё с нуля с использование присланного патча, ошибка осталась та же.

Отредактировано пользователем 22 июля 2020 г. 18:38:04(UTC)  | Причина: Не указана

Offline Местный  
#5 Оставлено : 23 июля 2020 г. 9:57:44(UTC)
Местный

Статус: Новичок

Группы: Участники
Зарегистрирован: 22.07.2020(UTC)
Сообщений: 2
Российская Федерация
Откуда: Сочи

Сказал(а) «Спасибо»: 1 раз
Автор: Александр Лавник Перейти к цитате
Здравствуйте.

К сожалению, для сборки расширения phpcades версии 2.0.14071 необходимо установить devel-пакет из неопубликованной еще сборки КриптоПро CSP 5.0.

Напишите в ЛС Ваш email, и я вышлю Вам нужный пакет.



Попросил devel пакет у коллеги по несчастью

Результат (пробовал разные g++ для сборок)

Код:

Makefile.unix:30: recipe for target 'PHPCadesCPSigners.o' failed
make: *** [PHPCadesCPSigners.o] Error 1
root@ruvds-lt45q:/opt/cprocsp/src/phpcades# update-alternatives --config g++    There are 3 choices for the alternative g++ (providing /usr/bin/g++).

  Selection    Path            Priority   Status
------------------------------------------------------------
  0            /usr/bin/g++-7   10        auto mode
  1            /usr/bin/g++-5   10        manual mode
  2            /usr/bin/g++-6   10        manual mode
* 3            /usr/bin/g++-7   10        manual mode

Press <enter> to keep the current choice[*], or type selection number: 2
update-alternatives: using /usr/bin/g++-6 to provide /usr/bin/g++ (g++) in manual mode
root@ruvds-lt45q:/opt/cprocsp/src/phpcades# make -f Makefile.unix               g++ -DLINUX  -DUNIX -DHAVE_LIMITS_H   -I/ -I/cpcsp -I/pki -I/pki/atl -I/pki/cppcades -I/pki/cplib -I/var/php-7.3.20 -I/var/php-7.3.20/main -I/var/php-7.3.20/Zend -I/var/php-7.3.20/TSRM  -DSIZEOF_VOID_P= -fPIC -DPIC -c -o PHPCadesCPSigners.o PHPCadesCPSigners.cpp
In file included from PHPCadesCPSigners.cpp:1:0:
stdafx.h:39:28: fatal error: CSP_WinDef.h: No such file or directory
     #include "CSP_WinDef.h"
                            ^
compilation terminated.
Makefile.unix:30: recipe for target 'PHPCadesCPSigners.o' failed
make: *** [PHPCadesCPSigners.o] Error 1
root@ruvds-lt45q:/opt/cprocsp/src/phpcades# update-alternatives --config g++
There are 3 choices for the alternative g++ (providing /usr/bin/g++).

  Selection    Path            Priority   Status
------------------------------------------------------------
  0            /usr/bin/g++-6   10        auto mode
  1            /usr/bin/g++-5   10        manual mode
* 2            /usr/bin/g++-6   10        manual mode
  3            /usr/bin/g++-7   10        manual mode

Press <enter> to keep the current choice[*], or type selection number: 1
update-alternatives: using /usr/bin/g++-5 to provide /usr/bin/g++ (g++) in manual mode
root@ruvds-lt45q:/opt/cprocsp/src/phpcades# make -f Makefile.unix
g++ -DLINUX  -DUNIX -DHAVE_LIMITS_H   -I/ -I/cpcsp -I/pki -I/pki/atl -I/pki/cppcades -I/pki/cplib -I/var/php-7.3.20 -I/var/php-7.3.20/main -I/var/php-7.3.20/Zend -I/var/php-7.3.20/TSRM  -DSIZEOF_VOID_P= -fPIC -DPIC -c -o PHPCadesCPSigners.o PHPCadesCPSigners.cpp
In file included from PHPCadesCPSigners.cpp:1:0:
stdafx.h:39:28: fatal error: CSP_WinDef.h: No such file or directory
compilation terminated.
Makefile.unix:30: recipe for target 'PHPCadesCPSigners.o' failed
make: *** [PHPCadesCPSigners.o] Error 1



Итог: ошибка в 1 в 1, на разных платформах (CentOs и Ubuntu)

stdafx.h:39:28: fatal error: CSP_WinDef.h: No such file or directory
#include "CSP_WinDef.h"



УРА! ВРоде собралось с последним пакетом devel

Код:

eval `/opt/cprocsp/src/doxygen/CSP/../setenv.sh --64`; make -f Makefile.unix


Это команда навела марафет! )))

Отредактировано пользователем 23 июля 2020 г. 10:29:46(UTC)  | Причина: Не указана

Offline Августина  
#6 Оставлено : 23 июля 2020 г. 10:54:45(UTC)
Августина

Статус: Участник

Группы: Участники
Зарегистрирован: 17.07.2020(UTC)
Сообщений: 18
Российская Федерация
Откуда: Москва

Сказал(а) «Спасибо»: 2 раз
Всё сдвинулось с мёртвой точки, в моём случае была проблема в том, что я пользуюсь fish shell'ом на сервере, и он не понимает backticks в команде eval.
Перешла в bash — появились другие ошибки. Буду смотреть.

Новая ошибка
Код:

[root@dev3 phpcades]# eval `/opt/cprocsp/src/doxygen/CSP/../setenv.sh --64`; make -f Makefile.unix
g++  -DLINUX  -DUNIX -DHAVE_LIMITS_H  -D_COMPACT -DHAVE_STDINT_H  -I/opt/cprocsp/include/ -I/opt/cprocsp/include/cpcsp -I/opt/cprocsp/include/pki -I/opt/cprocsp/include/pki/atl -I/opt/cprocsp/include/pki/cppcades -I/opt/cprocsp/include/pki/cplib -I/root/php-7.4.8 -I/root/php-7.4.8/main -I/root/php-7.4.8/Zend -I/root/php-7.4.8/TSRM  -DSIZEOF_VOID_P=8 -fPIC -DPIC -c -o PHPCadesCPSigners.o PHPCadesCPSigners.cpp
In file included from /root/php-7.4.8/Zend/zend_types.h:25:0,
                 from /root/php-7.4.8/Zend/zend.h:27,
                 from /root/php-7.4.8/main/php.h:33,
                 from stdafx.h:92,
                 from PHPCadesCPSigners.cpp:1:
/root/php-7.4.8/Zend/zend_portability.h:43:26: фатальная ошибка: zend_config.h: Нет такого файла или каталога
 # include <zend_config.h>

в исходниках с php делала ./configure
патч тоже использовала
При этом в папке Zend есть файл zend_config.32w.h

Итог: ./configure ругался на то, что нет sqlite3 нужной версии.
Решение: скачать пакет
Код:
yum install sqlite-devel.x86_64

Отредактировано пользователем 23 июля 2020 г. 11:55:48(UTC)  | Причина: Не указана

Offline Max BArev  
#7 Оставлено : 29 июля 2020 г. 12:21:26(UTC)
Max BArev

Статус: Новичок

Группы: Участники
Зарегистрирован: 29.07.2020(UTC)
Сообщений: 2
Откуда: Москва

Сказал(а) «Спасибо»: 2 раз
Автор: Александр Лавник Перейти к цитате
Здравствуйте.

К сожалению, для сборки расширения phpcades версии 2.0.14071 необходимо установить devel-пакет из неопубликованной еще сборки КриптоПро CSP 5.0.

Напишите в ЛС Ваш email, и я вышлю Вам нужный пакет.


Добрый день! А можно и мне тоже сей devel пакет?
Ошибка: fatal error: asn1/Attribute.h: No such file or directory
Offline Max BArev  
#8 Оставлено : 29 июля 2020 г. 12:23:16(UTC)
Max BArev

Статус: Новичок

Группы: Участники
Зарегистрирован: 29.07.2020(UTC)
Сообщений: 2
Откуда: Москва

Сказал(а) «Спасибо»: 2 раз
Автор: Местный Перейти к цитате
УРА! ВРоде собралось с последним пакетом devel


Приветствую коллега!
Можете угостить ссылкой на "последний пакет devel"?
Offline floodwm  
#9 Оставлено : 29 июля 2020 г. 23:32:08(UTC)
floodwm

Статус: Новичок

Группы: Участники
Зарегистрирован: 29.07.2020(UTC)
Сообщений: 1
Откуда: Дома

установить devel-пакет из неопубликованной еще сборки КриптоПро CSP 5.0.
И МНЕЕЕЕЕЕ ПАКЕТ ПОЖАЛУСТА ИЗ неопубликованной
Offline Александр Лавник  
#10 Оставлено : 30 июля 2020 г. 0:32:40(UTC)
Александр Лавник

Статус: Сотрудник

Группы: Участники
Зарегистрирован: 30.06.2016(UTC)
Сообщений: 2,189
Мужчина
Российская Федерация

Сказал «Спасибо»: 33 раз
Поблагодарили: 507 раз в 482 постах
Автор: floodwm Перейти к цитате
установить devel-пакет из неопубликованной еще сборки КриптоПро CSP 5.0.
И МНЕЕЕЕЕЕ ПАКЕТ ПОЖАЛУСТА ИЗ неопубликованной

Здравствуйте.

Отправил Вам на почту.
Техническую поддержку оказываем тут
Наша база знаний
thanks 1 пользователь поблагодарил Александр Лавник за этот пост.
Max BArev оставлено 30.07.2020(UTC)
Offline Александр Лавник  
#11 Оставлено : 30 июля 2020 г. 9:21:43(UTC)
Александр Лавник

Статус: Сотрудник

Группы: Участники
Зарегистрирован: 30.06.2016(UTC)
Сообщений: 2,189
Мужчина
Российская Федерация

Сказал «Спасибо»: 33 раз
Поблагодарили: 507 раз в 482 постах
Автор: Max BArev Перейти к цитате
Автор: Александр Лавник Перейти к цитате
Здравствуйте.

К сожалению, для сборки расширения phpcades версии 2.0.14071 необходимо установить devel-пакет из неопубликованной еще сборки КриптоПро CSP 5.0.

Напишите в ЛС Ваш email, и я вышлю Вам нужный пакет.


Добрый день! А можно и мне тоже сей devel пакет?
Ошибка: fatal error: asn1/Attribute.h: No such file or directory

Здравствуйте.

Отправил Вам на почту.
Техническую поддержку оказываем тут
Наша база знаний
thanks 1 пользователь поблагодарил Александр Лавник за этот пост.
Max BArev оставлено 30.07.2020(UTC)
Offline romach3  
#12 Оставлено : 14 августа 2020 г. 22:55:35(UTC)
romach3

Статус: Новичок

Группы: Участники
Зарегистрирован: 13.08.2020(UTC)
Сообщений: 1

Сказал(а) «Спасибо»: 1 раз
А можно мне тоже?

Такая же ошибка, как и у Max BArev "fatal error: asn1/Attribute.h: No such file or directory"
Offline nsknewbie  
#13 Оставлено : 7 сентября 2020 г. 13:50:53(UTC)
nsknewbie

Статус: Новичок

Группы: Участники
Зарегистрирован: 07.09.2020(UTC)
Сообщений: 1
Российская Федерация

Сказал(а) «Спасибо»: 1 раз
Добрый день. Отправьте, пожалуйста, и мне этот devel пакет на почту.
Offline Александр Лавник  
#14 Оставлено : 7 сентября 2020 г. 13:56:38(UTC)
Александр Лавник

Статус: Сотрудник

Группы: Участники
Зарегистрирован: 30.06.2016(UTC)
Сообщений: 2,189
Мужчина
Российская Федерация

Сказал «Спасибо»: 33 раз
Поблагодарили: 507 раз в 482 постах
Автор: nsknewbie Перейти к цитате
Добрый день. Отправьте, пожалуйста, и мне этот devel пакет на почту.

Здравствуйте.

Пакеты выложены сюда.
Техническую поддержку оказываем тут
Наша база знаний
thanks 2 пользователей поблагодарили Александр Лавник за этот пост.
nsknewbie оставлено 07.09.2020(UTC), romach3 оставлено 09.09.2020(UTC)
Offline Fedor A  
#15 Оставлено : 20 октября 2020 г. 15:50:37(UTC)
Fedor A

Статус: Новичок

Группы: Участники
Зарегистрирован: 20.10.2020(UTC)
Сообщений: 2

Автор: Александр Лавник Перейти к цитате
Автор: nsknewbie Перейти к цитате
Добрый день. Отправьте, пожалуйста, и мне этот devel пакет на почту.

Здравствуйте.

Пакеты выложены сюда.


Добрый день.

Разворачиваем на астре. Идем по инструкции:
https://docs.cryptopro.r...hpcades/phpcades-install

Установлены:
libboost-dev
php-dev
libxml2-dev

php-7.2.24

КриптоПро CSP 5.0.11455
КриптоПро ЭЦП SDK
devel lsb-cprocsp-devel_5.0.11863-5_all.deb
(пробовали и lsb-cprocsp-devel_5.0.11438-4_all.deb)

php успешно пропатчен.

Получаем ошибку:

Код:
root@astra:/opt/cprocsp/src/phpcades# eval `/opt/cprocsp/src/doxygen/CSP/../setenv.sh --64`; make -f Makefile.unix
No compiler specified... trying to guess
g++ found in the path
g++ -std=c++98 -D_GLIBCXX_USE_CXX11_ABI=0 -DLINUX  -DUNIX -DHAVE_LIMITS_H  -D_COMPACT -DHAVE_STDINT_H  -I/opt/cprocsp/include/ -I/opt/cprocsp/include/cpcsp -I/opt/cprocsp/include/pki -I/opt/cprocsp/include/pki/atl -I/opt/cprocsp/include/pki/cppcades -I/opt/cprocsp/include/pki/cplib -I/home/fedor/Документы/final/php-7.2.24 -I/home/fedor/Документы/final/php-7.2.24/main -I/home/fedor/Документы/final/php-7.2.24/Zend -I/home/fedor/Документы/final/php-7.2.24/TSRM  -DSIZEOF_VOID_P=8 -fPIC -DPIC -c -o PHPCadesCPSigners.o PHPCadesCPSigners.cpp
In file included from stdafx.h:39:0,
                 from PHPCadesCPSigners.cpp:1:
/opt/cprocsp/include/cpcsp/CSP_WinDef.h:484:152: note: #pragma message: Your application will require at least CryptoPro CSP 4.0 R3. You can use LEGACY_FORMAT_MESSAGE_IMPL to support older versions.
 #      pragma message ("Your application will require at least CryptoPro CSP 4.0 R3. You can use LEGACY_FORMAT_MESSAGE_IMPL to support older versions.")
                                                                                                                                                        ^
g++ -std=c++98 -D_GLIBCXX_USE_CXX11_ABI=0 -DLINUX  -DUNIX -DHAVE_LIMITS_H  -D_COMPACT -DHAVE_STDINT_H  -I/opt/cprocsp/include/ -I/opt/cprocsp/include/cpcsp -I/opt/cprocsp/include/pki -I/opt/cprocsp/include/pki/atl -I/opt/cprocsp/include/pki/cppcades -I/opt/cprocsp/include/pki/cplib -I/home/fedor/Документы/final/php-7.2.24 -I/home/fedor/Документы/final/php-7.2.24/main -I/home/fedor/Документы/final/php-7.2.24/Zend -I/home/fedor/Документы/final/php-7.2.24/TSRM  -DSIZEOF_VOID_P=8 -fPIC -DPIC -c -o PHPCadesCPSigner.o PHPCadesCPSigner.cpp
In file included from stdafx.h:39:0,
                 from PHPCadesCPSigner.cpp:1:
/opt/cprocsp/include/cpcsp/CSP_WinDef.h:484:152: note: #pragma message: Your application will require at least CryptoPro CSP 4.0 R3. You can use LEGACY_FORMAT_MESSAGE_IMPL to support older versions.
 #      pragma message ("Your application will require at least CryptoPro CSP 4.0 R3. You can use LEGACY_FORMAT_MESSAGE_IMPL to support older versions.")
                                                                                                                                                        ^
g++ -std=c++98 -D_GLIBCXX_USE_CXX11_ABI=0 -DLINUX  -DUNIX -DHAVE_LIMITS_H  -D_COMPACT -DHAVE_STDINT_H  -I/opt/cprocsp/include/ -I/opt/cprocsp/include/cpcsp -I/opt/cprocsp/include/pki -I/opt/cprocsp/include/pki/atl -I/opt/cprocsp/include/pki/cppcades -I/opt/cprocsp/include/pki/cplib -I/home/fedor/Документы/final/php-7.2.24 -I/home/fedor/Документы/final/php-7.2.24/main -I/home/fedor/Документы/final/php-7.2.24/Zend -I/home/fedor/Документы/final/php-7.2.24/TSRM  -DSIZEOF_VOID_P=8 -fPIC -DPIC -c -o PHPCadesCPExtendedKeyUsage.o PHPCadesCPExtendedKeyUsage.cpp
In file included from stdafx.h:39:0,
                 from PHPCadesCPExtendedKeyUsage.cpp:1:
/opt/cprocsp/include/cpcsp/CSP_WinDef.h:484:152: note: #pragma message: Your application will require at least CryptoPro CSP 4.0 R3. You can use LEGACY_FORMAT_MESSAGE_IMPL to support older versions.
 #      pragma message ("Your application will require at least CryptoPro CSP 4.0 R3. You can use LEGACY_FORMAT_MESSAGE_IMPL to support older versions.")
                                                                                                                                                        ^
g++ -std=c++98 -D_GLIBCXX_USE_CXX11_ABI=0 -DLINUX  -DUNIX -DHAVE_LIMITS_H  -D_COMPACT -DHAVE_STDINT_H  -I/opt/cprocsp/include/ -I/opt/cprocsp/include/cpcsp -I/opt/cprocsp/include/pki -I/opt/cprocsp/include/pki/atl -I/opt/cprocsp/include/pki/cppcades -I/opt/cprocsp/include/pki/cplib -I/home/fedor/Документы/final/php-7.2.24 -I/home/fedor/Документы/final/php-7.2.24/main -I/home/fedor/Документы/final/php-7.2.24/Zend -I/home/fedor/Документы/final/php-7.2.24/TSRM  -DSIZEOF_VOID_P=8 -fPIC -DPIC -c -o PHPCadesCPAttribute.o PHPCadesCPAttribute.cpp
In file included from stdafx.h:39:0,
                 from PHPCadesCPAttribute.cpp:1:
/opt/cprocsp/include/cpcsp/CSP_WinDef.h:484:152: note: #pragma message: Your application will require at least CryptoPro CSP 4.0 R3. You can use LEGACY_FORMAT_MESSAGE_IMPL to support older versions.
 #      pragma message ("Your application will require at least CryptoPro CSP 4.0 R3. You can use LEGACY_FORMAT_MESSAGE_IMPL to support older versions.")
                                                                                                                                                        ^
g++ -std=c++98 -D_GLIBCXX_USE_CXX11_ABI=0 -DLINUX  -DUNIX -DHAVE_LIMITS_H  -D_COMPACT -DHAVE_STDINT_H  -I/opt/cprocsp/include/ -I/opt/cprocsp/include/cpcsp -I/opt/cprocsp/include/pki -I/opt/cprocsp/include/pki/atl -I/opt/cprocsp/include/pki/cppcades -I/opt/cprocsp/include/pki/cplib -I/home/fedor/Документы/final/php-7.2.24 -I/home/fedor/Документы/final/php-7.2.24/main -I/home/fedor/Документы/final/php-7.2.24/Zend -I/home/fedor/Документы/final/php-7.2.24/TSRM  -DSIZEOF_VOID_P=8 -fPIC -DPIC -c -o PHPCadesCPEKU.o PHPCadesCPEKU.cpp
In file included from stdafx.h:39:0,
                 from PHPCadesCPEKU.cpp:1:
/opt/cprocsp/include/cpcsp/CSP_WinDef.h:484:152: note: #pragma message: Your application will require at least CryptoPro CSP 4.0 R3. You can use LEGACY_FORMAT_MESSAGE_IMPL to support older versions.
 #      pragma message ("Your application will require at least CryptoPro CSP 4.0 R3. You can use LEGACY_FORMAT_MESSAGE_IMPL to support older versions.")
                                                                                                                                                        ^
g++ -std=c++98 -D_GLIBCXX_USE_CXX11_ABI=0 -DLINUX  -DUNIX -DHAVE_LIMITS_H  -D_COMPACT -DHAVE_STDINT_H  -I/opt/cprocsp/include/ -I/opt/cprocsp/include/cpcsp -I/opt/cprocsp/include/pki -I/opt/cprocsp/include/pki/atl -I/opt/cprocsp/include/pki/cppcades -I/opt/cprocsp/include/pki/cplib -I/home/fedor/Документы/final/php-7.2.24 -I/home/fedor/Документы/final/php-7.2.24/main -I/home/fedor/Документы/final/php-7.2.24/Zend -I/home/fedor/Документы/final/php-7.2.24/TSRM  -DSIZEOF_VOID_P=8 -fPIC -DPIC -c -o PHPCadesCPEKUs.o PHPCadesCPEKUs.cpp
In file included from stdafx.h:39:0,
                 from PHPCadesCPEKUs.cpp:1:
/opt/cprocsp/include/cpcsp/CSP_WinDef.h:484:152: note: #pragma message: Your application will require at least CryptoPro CSP 4.0 R3. You can use LEGACY_FORMAT_MESSAGE_IMPL to support older versions.
 #      pragma message ("Your application will require at least CryptoPro CSP 4.0 R3. You can use LEGACY_FORMAT_MESSAGE_IMPL to support older versions.")
                                                                                                                                                        ^
g++ -std=c++98 -D_GLIBCXX_USE_CXX11_ABI=0 -DLINUX  -DUNIX -DHAVE_LIMITS_H  -D_COMPACT -DHAVE_STDINT_H  -I/opt/cprocsp/include/ -I/opt/cprocsp/include/cpcsp -I/opt/cprocsp/include/pki -I/opt/cprocsp/include/pki/atl -I/opt/cprocsp/include/pki/cppcades -I/opt/cprocsp/include/pki/cplib -I/home/fedor/Документы/final/php-7.2.24 -I/home/fedor/Документы/final/php-7.2.24/main -I/home/fedor/Документы/final/php-7.2.24/Zend -I/home/fedor/Документы/final/php-7.2.24/TSRM  -DSIZEOF_VOID_P=8 -fPIC -DPIC -c -o PHPCadesCPBasicConstraints.o PHPCadesCPBasicConstraints.cpp
In file included from stdafx.h:39:0,
                 from PHPCadesCPBasicConstraints.cpp:1:
/opt/cprocsp/include/cpcsp/CSP_WinDef.h:484:152: note: #pragma message: Your application will require at least CryptoPro CSP 4.0 R3. You can use LEGACY_FORMAT_MESSAGE_IMPL to support older versions.
 #      pragma message ("Your application will require at least CryptoPro CSP 4.0 R3. You can use LEGACY_FORMAT_MESSAGE_IMPL to support older versions.")
                                                                                                                                                        ^
g++ -std=c++98 -D_GLIBCXX_USE_CXX11_ABI=0 -DLINUX  -DUNIX -DHAVE_LIMITS_H  -D_COMPACT -DHAVE_STDINT_H  -I/opt/cprocsp/include/ -I/opt/cprocsp/include/cpcsp -I/opt/cprocsp/include/pki -I/opt/cprocsp/include/pki/atl -I/opt/cprocsp/include/pki/cppcades -I/opt/cprocsp/include/pki/cplib -I/home/fedor/Документы/final/php-7.2.24 -I/home/fedor/Документы/final/php-7.2.24/main -I/home/fedor/Документы/final/php-7.2.24/Zend -I/home/fedor/Документы/final/php-7.2.24/TSRM  -DSIZEOF_VOID_P=8 -fPIC -DPIC -c -o PHPCadesCPSignedData.o PHPCadesCPSignedData.cpp
In file included from stdafx.h:39:0,
                 from PHPCadesCPSignedData.cpp:1:
/opt/cprocsp/include/cpcsp/CSP_WinDef.h:484:152: note: #pragma message: Your application will require at least CryptoPro CSP 4.0 R3. You can use LEGACY_FORMAT_MESSAGE_IMPL to support older versions.
 #      pragma message ("Your application will require at least CryptoPro CSP 4.0 R3. You can use LEGACY_FORMAT_MESSAGE_IMPL to support older versions.")
                                                                                                                                                        ^
PHPCadesCPSignedData.cpp: In function ‘void zim_CPSignedData_SignHash(zend_execute_data*, zval*)’:
PHPCadesCPSignedData.cpp:69:31: error: ‘sig_ce’ was not declared in this scope
                               sig_ce, &zHashedData, hash_dat_class_entry,
                               ^~~~~~
PHPCadesCPSignedData.cpp:69:53: error: ‘hash_dat_class_entry’ was not declared in this scope
                               sig_ce, &zHashedData, hash_dat_class_entry,
                                                     ^~~~~~~~~~~~~~~~~~~~
PHPCadesCPSignedData.cpp:76:5: error: ‘sig_obj’ was not declared in this scope
     sig_obj *pSigner =
     ^~~~~~~
PHPCadesCPSignedData.cpp:76:14: error: ‘pSigner’ was not declared in this scope
     sig_obj *pSigner =
              ^~~~~~~
PHPCadesCPSignedData.cpp:77:19: error: expected primary-expression before ‘)’ token
         (sig_obj *)zend_object_store_get_object(zSigner TSRMLS_CC);
                   ^
PHPCadesCPSignedData.cpp:78:5: error: ‘hash_dat_obj’ was not declared in this scope
     hash_dat_obj *pHashedData =
     ^~~~~~~~~~~~
PHPCadesCPSignedData.cpp:78:19: error: ‘pHashedData’ was not declared in this scope
     hash_dat_obj *pHashedData =
                   ^~~~~~~~~~~
PHPCadesCPSignedData.cpp:79:24: error: expected primary-expression before ‘)’ token
         (hash_dat_obj *)zend_object_store_get_object(zHashedData TSRMLS_CC);
                        ^
PHPCadesCPSignedData.cpp:81:5: error: ‘sig_dat_obj’ was not declared in this scope
     sig_dat_obj *obj =
     ^~~~~~~~~~~
PHPCadesCPSignedData.cpp:81:18: error: ‘obj’ was not declared in this scope
     sig_dat_obj *obj =
                  ^~~
PHPCadesCPSignedData.cpp:82:23: error: expected primary-expression before ‘)’ token
         (sig_dat_obj *)zend_object_store_get_object(getThis() TSRMLS_CC);
                       ^
Makefile.unix:30: ошибка выполнения рецепта для цели «PHPCadesCPSignedData.o»
make: *** [PHPCadesCPSignedData.o] Ошибка 1


Подскажите, что делается не так.

Отредактировано пользователем 20 октября 2020 г. 16:03:35(UTC)  | Причина: Не указана

RSS Лента  Atom Лента
Пользователи, просматривающие эту тему
Быстрый переход  
Вы не можете создавать новые темы в этом форуме.
Вы не можете отвечать в этом форуме.
Вы не можете удалять Ваши сообщения в этом форуме.
Вы не можете редактировать Ваши сообщения в этом форуме.
Вы не можете создавать опросы в этом форуме.
Вы не можете голосовать в этом форуме.