logo
Добро пожаловать, Гость! Чтобы использовать все возможности Вход или Регистрация.

Уведомление

Icon
Error

Опции
К последнему сообщению К первому непрочитанному
Offline chirkovAS  
#1 Оставлено : 12 июля 2018 г. 6:55:00(UTC)
chirkovAS

Статус: Новичок

Группы: Участники
Зарегистрирован: 19.06.2018(UTC)
Сообщений: 4
Российская Федерация
Откуда: Челябинск

Есть контейнер Docker (Debian), установлен крипто про, скопировал контейнер с закрытым ключом в /var/opt/cprocsp/keys/root/.
Если выполнить команду
Код:
./csptest -keyset -enum_cont -verifycontext -fqcn -machinekeys
, то контейнера из /var/opt/cprocsp/keys/root/ не видно. Если убрать -machinekeys, то контейнер есть
Версия крипто про
Код:
CSP (Type:80) v4.0.9014 KC1 Release Ver:4.0.9842 OS:Linux CPU:AMD64 FastCode:READY:SSE2.

Перед установкой пакетов крипто про устанавливал эти зависимости:
Код:
sudo apt install lsb lsb-core alien

Добавил сертификат, sertmgr его видит. Пытаюсь подписать, получаю ошибку:
Код:
Can't open certificate store: 'My'.
Error: No certificate found.


Подскажите, в чём ошибка? Может не хватает зависимостей?

Отредактировано пользователем 12 июля 2018 г. 8:26:32(UTC)  | Причина: Не указана

Offline chirkovAS  
#2 Оставлено : 12 июля 2018 г. 8:27:07(UTC)
chirkovAS

Статус: Новичок

Группы: Участники
Зарегистрирован: 19.06.2018(UTC)
Сообщений: 4
Российская Федерация
Откуда: Челябинск

Автор: chirkovAS Перейти к цитате
Есть контейнер Docker (Debian), установлен крипто про, скопировал контейнер с закрытым ключом в /var/opt/cprocsp/keys/root/.
Если выполнить команду
Код:
./csptest -keyset -enum_cont -verifycontext -fqcn -machinekeys
, то контейнера из /var/opt/cprocsp/keys/root/ не видно. Если убрать -machinekeys, то контейнер есть.
Добавил сертификат, sertmgr его видит. Пытаюсь подписать, получаю ошибку:
Код:
Can't open certificate store: 'My'.
Error: No certificate found.

Версия крипто про
Код:
CSP (Type:80) v4.0.9014 KC1 Release Ver:4.0.9842 OS:Linux CPU:AMD64 FastCode:READY:SSE2.

Перед установкой пакетов крипто про устанавливал эти зависимости:
Код:
sudo apt install lsb lsb-core alien



Подскажите, в чём ошибка? Может не хватает зависимостей?


Разобрался - проблема была с правами докера

Отредактировано пользователем 12 июля 2018 г. 8:27:51(UTC)  | Причина: Не указана

RSS Лента  Atom Лента
Пользователи, просматривающие эту тему
Быстрый переход  
Вы не можете создавать новые темы в этом форуме.
Вы не можете отвечать в этом форуме.
Вы не можете удалять Ваши сообщения в этом форуме.
Вы не можете редактировать Ваши сообщения в этом форуме.
Вы не можете создавать опросы в этом форуме.
Вы не можете голосовать в этом форуме.