logo
Добро пожаловать, Гость! Чтобы использовать все возможности Вход или Регистрация.

Уведомление

Icon
Error

Опции
К последнему сообщению К первому непрочитанному
Offline valaam123  
#1 Оставлено : 7 августа 2017 г. 9:00:54(UTC)
valaam123

Статус: Участник

Группы: Участники
Зарегистрирован: 05.12.2013(UTC)
Сообщений: 27
Российская Федерация

Сказал(а) «Спасибо»: 2 раз
CSP 4.0.0_0
Код:
root@unix:/ # /opt/cprocsp/bin/amd64/ocsputil
Shared object "libocspcli.so.2" not found, required by "ocsputil"

root@unix:/ # /opt/cprocsp/bin/amd64/tsputil
Shared object "libtspcli.so.2" not found, required by "tsputil"

root@unix:/ # whereis libtspcli.so.2
libtspcli.so.2: /opt/cprocsp/lib/amd64/libtspcli.so.2

Скажите пожалуйста почему ocsputil и tsputil не видят библиотеки?

Код:
root@unix:/ # ldd /opt/cprocsp/bin/amd64/ocsputil
/opt/cprocsp/bin/amd64/ocsputil:
        libocspcli.so.2 => not found (0)
        libcapi10.so.4 => not found (0)
        libcapi20.so.4 => not found (0)
        librdrsup.so.4 => not found (0)
        libocsp.so.2 => not found (0)
        libcpalloc.so.0 => not found (0)
        libstdc++.so.6 => /usr/local/lib/gcc5/libstdc++.so.6 (0x800966000)
        libm.so.5 => /lib/libm.so.5 (0x800cee000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x800f19000)
        libc.so.7 => /lib/libc.so.7 (0x801127000)

root@unix:/ # ls /opt/cprocsp/lib/amd64
.dummy16                        libcpasn1.so.4                  libcpui.so.4                    libocspcli.so.2.0.0             librdrrndmbio_tui.so            liburlretrieve.so
.dummy21                        libcpcurl.a                     libcsp.so                       libpkivalidator.so              librdrrndmbio_tui.so.4          liburlretrieve.so.4
libcades.so                     libcpcurl.so                    libcsp.so.4                     libpkivalidator.so.2            librdrsup.so                    libxmlsec-mscrypto.so
libcades.so.2                   libcpcurl.so.6                  libenroll.so                    libpkivalidator.so.2.0.0        librdrsup.so.4                  libxmlsec-mscrypto.so.2
libcades.so.2.0.0               libcpext.so                     libenroll.so.4                  librdrdsrf.so                   libssp.so                       libxmlsec-mscrypto.so.2.0.0
libcapi10.so                    libcpext.so.4                   libjemalloc.so                  librdrdsrf.so.4                 libssp.so.4                     libxmlsec.so
libcapi10.so.4                  libcplib.so                     libjemalloc.so.0                librdrfat12.so                  libtsp.so                       libxmlsec.so.2
libcapi20.so                    libcplib.so.4                   libocsp.so                      librdrfat12.so.4                libtsp.so.2                     libxmlsec.so.2.0.0
libcapi20.so.4                  libcppcades.so                  libocsp.so.2                    librdrrdr.so                    libtsp.so.2.0.0
libcpalloc.so                   libcppcades.so.2                libocsp.so.2.0.0                librdrrdr.so.4                  libtspcli.so
libcpalloc.so.0                 libcppcades.so.2.0.0            libocspcli.so                   librdrrndm.so                   libtspcli.so.2
libcpasn1.so                    libcpui.so                      libocspcli.so.2                 librdrrndm.so.4                 libtspcli.so.2.0.0
Offline Андрей Емельянов  
#2 Оставлено : 7 августа 2017 г. 9:31:27(UTC)
Андрей Емельянов

Статус: Сотрудник

Группы: Участники
Зарегистрирован: 11.03.2013(UTC)
Сообщений: 740
Мужчина
Российская Федерация
Откуда: Оттуда

Сказал «Спасибо»: 1 раз
Поблагодарили: 136 раз в 133 постах
Добрый день.
Приложите информацию:
- какой именно linux
- перечень установленных пакетов КритпоПро CSP 4.0
- точную версию сборки CSP 4.0
Код:
/opt/cprocsp/bin/amd64/csptest -oid -general

Техническую поддержку оказываем тут
Наша база знаний
Offline valaam123  
#3 Оставлено : 8 августа 2017 г. 5:41:07(UTC)
valaam123

Статус: Участник

Группы: Участники
Зарегистрирован: 05.12.2013(UTC)
Сообщений: 27
Российская Федерация

Сказал(а) «Спасибо»: 2 раз
OS FreeBSD 11.0-RELEASE
Код:
root@unix:/# pkg info | grep cpro
cpro-base-4.0.0_0              CryptoPro CSP base.
cpro-capilite-64-4.0.0_0       CryptoAPI lite(64bit).
cpro-curl-64-4.0.0_0           Curl GOST SSPI (64bit)
cpro-kc1-64-4.0.0_0            CryptoPro CSP libraries and binaries(64bit).
cpro-rdr-64-4.0.0_0            CryptoPro CSP readers and support library(64bit).

Код:
root@unix:/# /opt/cprocsp/bin/amd64/csptest -oid -general
CSP (Type:80) v4.0.9015 KC1 Release Ver:4.0.9907 OS:FreeBSD CPU:AMD64 FastCode:READY:SSSE3.
CryptAcquireContext succeeded.HCRYPTPROV: 34391413027
Total: SYS: 0.000 sec USR: 0.016 sec UTC: 0.016 sec
[ErrorCode: 0x00000000]

Offline Андрей Емельянов  
#4 Оставлено : 8 августа 2017 г. 8:33:53(UTC)
Андрей Емельянов

Статус: Сотрудник

Группы: Участники
Зарегистрирован: 11.03.2013(UTC)
Сообщений: 740
Мужчина
Российская Федерация
Откуда: Оттуда

Сказал «Спасибо»: 1 раз
Поблагодарили: 136 раз в 133 постах
Обновите КриптоПро CSP 4.0 до актуально версии.
Все актуальные версии CSP:
https://www.cryptopro.ru/products/csp/downloads
CSP 4.0 R3 для FreeBSD (x64):
https://www.cryptopro.ru...0/9914/freebsd-amd64.tgz

Для работы с библиотеками клиентов необходимо установить пакеты cades.
Все актуальные версии cades:
https://www.cryptopro.ru/products/cades/downloads
КриптоПро ЭЦП SDK 2.0 для FreeBSD (x64):
https://www.cryptopro.ru.../cades_fbsd_amd64.tar.gz

Отредактировано пользователем 8 августа 2017 г. 8:34:38(UTC)  | Причина: Не указана

Техническую поддержку оказываем тут
Наша база знаний
thanks 1 пользователь поблагодарил Андрей Емельянов за этот пост.
valaam123 оставлено 09.08.2017(UTC)
Offline valaam123  
#5 Оставлено : 8 августа 2017 г. 11:55:44(UTC)
valaam123

Статус: Участник

Группы: Участники
Зарегистрирован: 05.12.2013(UTC)
Сообщений: 27
Российская Федерация

Сказал(а) «Спасибо»: 2 раз
Спасибо за ссылки:
freebsd-amd64.tgz - встал без проблем
Код:
root@unix:/# /opt/cprocsp/bin/amd64/csptest -oid -general
CSP (Type:80) v4.0.9016 KC1 Release Ver:4.0.9914 OS:FreeBSD CPU:AMD64 FastCode:READY:SSSE3.
CryptAcquireContext succeeded.HCRYPTPROV: 34391413171
Total: SYS: 0.008 sec USR: 0.008 sec UTC: 0.008 sec
[ErrorCode: 0x00000000]


а вот MD5 (cades_fbsd_amd64.tar.gz) = 6be1c10a9772bd4fd4ab35232dc8368e - скачен по приложенной ссылке.
Код:

root@unix:/# tar zxf freebsd-amd64.tgz
cpro-devel-4.0.0_0.tbz                 1197991 Feb 27 13:38
cprocsp-pki-2.0.0-amd64-cades.tar.gz   10840K  Aug  1 11:25

root@unix:/# pkg add cpro-devel-4.0.0_0.tbz
Installing cpro-devel-4.0.0_0...
pkg: wrong architecture: freebsd:10:i386 instead of FreeBSD:11:amd64

Failed to install the following 1 package(s): cpro-devel-4.0.0_0.tbz


пробуем второй архив: cprocsp-pki-2.0.0-amd64-cades.tar.gz
почему то fbsd_pki_sdk_install.sh, fbsd_pki_sdk_uninstall.sh не имеют бита запуска
Код:
root@unix:/# tar zxf cprocsp-pki-2.0.0-amd64-cades.tar.gz
root@unix:/# chmod +x fbsd_pki_sdk_install.sh
root@unix:/# chmod +x fbsd_pki_sdk_uninstall.sh
root@unix:/# ./fbsd_pki_sdk_install.sh
[: : bad number
opt -> /opt
opt/cprocsp -> /opt/cprocsp
opt/cprocsp/bin -> /opt/cprocsp/bin
opt/cprocsp/bin/amd64 -> /opt/cprocsp/bin/amd64
opt/cprocsp/bin/amd64/ocsputil -> /opt/cprocsp/bin/amd64/ocsputil
opt/cprocsp/bin/amd64/tsputil -> /opt/cprocsp/bin/amd64/tsputil
opt/cprocsp/include -> /opt/cprocsp/include
opt/cprocsp/include/pki -> /opt/cprocsp/include/pki
... сократил а то много ...
opt/cprocsp/src/CadesSamples/cades_samples.unix.mk -> /opt/cprocsp/src/CadesSamples/cades_samples.unix.mk
./fbsd_pki_sdk_install.sh: source: not found
Install complete.

что за ошибки? пакет нормально установился?
Код:
[: : bad number
./fbsd_pki_sdk_install.sh: source: not found


хотя если проверять запуск:
Код:
root@unix:/# ocsputil
ocsputil: no command specified
Run ocsputil --help to see the list of options and commands
[ReturnCode: 0x1]
root@unix:/# tsputil
tsputil: no command specified
Run tsputil --help to see the list of options and commands
[ReturnCode: 0x1]


получается, что предыдущая сборка была кривой?
Код:
MD5(freebsd-amd64_4.0.9015)  = 93723e1289239ef929ce889ab80f9827 
MD5(cades_fbsd_amd64.tar.gz) = d19530720098ded6ad9ff3370759acc5
Offline 32stos  
#6 Оставлено : 9 августа 2017 г. 10:23:42(UTC)
32stos

Статус: Участник

Группы: Участники
Зарегистрирован: 17.07.2015(UTC)
Сообщений: 24
Российская Федерация

Поблагодарили: 3 раз в 3 постах
Добрый день

Нужно добавить бит выполнения для /opt/cprocsp/sbin/amd64/postinstall.cades и выполнить его.
Для установки devel пакета нужно поставить пакет compat10x
Offline valaam123  
#7 Оставлено : 9 августа 2017 г. 11:06:59(UTC)
valaam123

Статус: Участник

Группы: Участники
Зарегистрирован: 05.12.2013(UTC)
Сообщений: 27
Российская Федерация

Сказал(а) «Спасибо»: 2 раз
Автор: 32stos Перейти к цитате
Добрый день

Нужно добавить бит выполнения для /opt/cprocsp/sbin/amd64/postinstall.cades и выполнить его.


Выполнил он мне перезаписал мои лицензии на свои временные.

Offline valaam123  
#8 Оставлено : 25 января 2018 г. 6:49:10(UTC)
valaam123

Статус: Участник

Группы: Участники
Зарегистрирован: 05.12.2013(UTC)
Сообщений: 27
Российская Федерация

Сказал(а) «Спасибо»: 2 раз
Сегодня поставил обновленную версию: [CSP 4.0.9929 : https://www.cryptopro.ru...0/9929/freebsd-amd64.tgz]
и cades 2.0 [4.0.9921 : https://www.cryptopro.ru.../cades_fbsd_amd64.tar.gz]
Код:
FreeBSD 10.4-RELEASE GENERIC  amd64

[root@unix ~]# ./fbsd_pki_sdk_install.sh
...
opt/cprocsp/src/CadesSamples/cades_samples.unix.mk -> /opt/cprocsp/src/CadesSamples/cades_samples.unix.mk
Shared object "libocspcli.so.2" not found, required by "ocsputil"
Shared object "libtspcli.so.2" not found, required by "tsputil"
Install complete.

[root@unix]#  pkg info | grep cpro
cpro-base-4.0.9929_0           CryptoPro CSP base.
cpro-capilite-64-4.0.9929_0    CryptoAPI lite(64bit).
cpro-curl-64-4.0.9929_0        Curl GOST SSPI (64bit)
cpro-devel-4.0.9929_0          CryptoPro CSP development (headers and test sources).
cpro-kc1-64-4.0.9929_0         CryptoPro CSP libraries and binaries(64bit).
cpro-rdr-64-4.0.9929_0         CryptoPro CSP readers and support library(64bit).
cpro-rdr-emv-64-4.0.9929_0     EMV/GEMALTO support module for CryptoPro CSP (64 bit)
cpro-rdr-rutoken-64-4.0.9929_0 Rutoken reader (64bit)


[root@unix]# /opt/cprocsp/bin/amd64/csptest -oid -general
CSP (Type:80) v4.0.9016 KC1 Release Ver:4.0.9929 OS:FreeBSD CPU:AMD64 FastCode:READY:SSSE3.
CryptAcquireContext succeeded.HCRYPTPROV: 34393469379
Total: SYS: 0.000 sec USR: 0.008 sec UTC: 0.016 sec
[ErrorCode: 0x00000000]

[root@unix]# /opt/cprocsp/bin/amd64/tsputil
Shared object "libtspcli.so.2" not found, required by "tsputil"
[root@unix]# /opt/cprocsp/bin/amd64/ocsputil
Shared object "libocspcli.so.2" not found, required by "ocsputil"

[root@unix]# ls -la /opt/cprocsp/lib/amd64/lib*cli*
-rwxr-xr-x  1 root  wheel  4650855 Jan 25 09:06 /opt/cprocsp/lib/amd64/libocspcli.so
-rwxr-xr-x  1 root  wheel  4650855 Jan 25 09:06 /opt/cprocsp/lib/amd64/libocspcli.so.2
-rwxr-xr-x  1 root  wheel  4650855 Jan 25 09:06 /opt/cprocsp/lib/amd64/libocspcli.so.2.0.0
-rwxr-xr-x  1 root  wheel  4574247 Jan 25 09:06 /opt/cprocsp/lib/amd64/libtspcli.so
-rwxr-xr-x  1 root  wheel  4574247 Jan 25 09:06 /opt/cprocsp/lib/amd64/libtspcli.so.2
-rwxr-xr-x  1 root  wheel  4574247 Jan 25 09:06 /opt/cprocsp/lib/amd64/libtspcli.so.2.0.0

[root@unix]# ldd /opt/cprocsp/bin/amd64/tsputil
/opt/cprocsp/bin/amd64/tsputil:
        libtspcli.so.2 => not found (0)
        libtsp.so.2 => not found (0)
        libcapi10.so.4 => not found (0)
        libcapi20.so.4 => not found (0)
        librdrsup.so.4 => not found (0)
        libcpalloc.so.0 => not found (0)
        libstdc++.so.6 => /usr/local/lib/gcc6/libstdc++.so.6 (0x800965000)
        libm.so.5 => /lib/libm.so.5 (0x800cfa000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x800f23000)
        libc.so.7 => /lib/libc.so.7 (0x801131000)


опять утилиты не видят библиотек, ручной запуск /opt/cprocsp/sbin/amd64/postinstall.cades проблему не устраняет
прописываем руками путь в /etc/rc.conf
ldconfig_paths="... /opt/cprocsp/lib/amd64"
Код:
[root@unix]# ldd /opt/cprocsp/bin/amd64/ocsputil
/opt/cprocsp/bin/amd64/ocsputil:
        libocspcli.so.2 => /opt/cprocsp/lib/amd64/libocspcli.so.2 (0x800a00000)
        libcapi10.so.4 => /opt/cprocsp/lib/amd64/libcapi10.so.4 (0x800776000)
        libcapi20.so.4 => /opt/cprocsp/lib/amd64/libcapi20.so.4 (0x801000000)
        librdrsup.so.4 => /opt/cprocsp/lib/amd64/librdrsup.so.4 (0x800e22000)
        libocsp.so.2 => /opt/cprocsp/lib/amd64/libocsp.so.2 (0x801800000)
        libcpalloc.so.0 => /opt/cprocsp/lib/amd64/libcpalloc.so.0 (0x801c22000)
        libstdc++.so.6 => /usr/local/lib/gcc6/libstdc++.so.6 (0x801d23000)
        libm.so.5 => /lib/libm.so.5 (0x8020b8000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x8022e1000)
        libc.so.7 => /lib/libc.so.7 (0x8024ef000)
        libthr.so.3 => /lib/libthr.so.3 (0x80289e000)
        libcpext.so.4 => /opt/cprocsp/lib/amd64/libcpext.so.4 (0x802ac2000)
        liburlretrieve.so.4 => /opt/cprocsp/lib/amd64/liburlretrieve.so.4 (0x802c54000)
        libcpasn1.so.4 => /opt/cprocsp/lib/amd64/libcpasn1.so.4 (0x802e00000)
        libjemalloc.so.0 => /opt/cprocsp/lib/amd64/libjemalloc.so.0 (0x803609000)
        libcplib.so.4 => /opt/cprocsp/lib/amd64/libcplib.so.4 (0x80373c000)

[root@unix]# /opt/cprocsp/bin/amd64/ocsputil -V
ocsputil 2.0
[ReturnCode: 0x0]
Segmentation fault (core dumped)

[root@unix]# gdb /opt/cprocsp/bin/amd64/ocsputil ocsputil.core
GNU gdb 6.1.1 [FreeBSD]
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "amd64-marcel-freebsd"...(no debugging symbols found)...
Core was generated by `/opt/cprocsp/bin/amd64/ocsputil'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /opt/cprocsp/lib/amd64/libocspcli.so.2...(no debugging symbols found)...done.
Loaded symbols for /opt/cprocsp/lib/amd64/libocspcli.so.2
Reading symbols from /opt/cprocsp/lib/amd64/libcapi10.so.4...(no debugging symbols found)...done.
Loaded symbols for /opt/cprocsp/lib/amd64/libcapi10.so.4
Reading symbols from /opt/cprocsp/lib/amd64/libcapi20.so.4...(no debugging symbols found)...done.
Loaded symbols for /opt/cprocsp/lib/amd64/libcapi20.so.4
Reading symbols from /opt/cprocsp/lib/amd64/librdrsup.so.4...(no debugging symbols found)...done.
Loaded symbols for /opt/cprocsp/lib/amd64/librdrsup.so.4
Reading symbols from /opt/cprocsp/lib/amd64/libocsp.so.2...(no debugging symbols found)...done.
Loaded symbols for /opt/cprocsp/lib/amd64/libocsp.so.2
Reading symbols from /opt/cprocsp/lib/amd64/libcpalloc.so.0...(no debugging symbols found)...done.
Loaded symbols for /opt/cprocsp/lib/amd64/libcpalloc.so.0
Reading symbols from /usr/local/lib/gcc6/libstdc++.so.6...(no debugging symbols found)...done.
Loaded symbols for /usr/local/lib/gcc6/libstdc++.so.6
Reading symbols from /lib/libm.so.5...(no debugging symbols found)...done.
Loaded symbols for /lib/libm.so.5
Reading symbols from /lib/libgcc_s.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib/libgcc_s.so.1
Reading symbols from /lib/libc.so.7...(no debugging symbols found)...done.
Loaded symbols for /lib/libc.so.7
Reading symbols from /lib/libthr.so.3...(no debugging symbols found)...done.
Loaded symbols for /lib/libthr.so.3
Reading symbols from /opt/cprocsp/lib/amd64/libcpext.so.4...(no debugging symbols found)...done.
Loaded symbols for /opt/cprocsp/lib/amd64/libcpext.so.4
Reading symbols from /opt/cprocsp/lib/amd64/liburlretrieve.so.4...(no debugging symbols found)...done.
Loaded symbols for /opt/cprocsp/lib/amd64/liburlretrieve.so.4
Reading symbols from /opt/cprocsp/lib/amd64/libcpasn1.so.4...(no debugging symbols found)...done.
Loaded symbols for /opt/cprocsp/lib/amd64/libcpasn1.so.4
Reading symbols from /opt/cprocsp/lib/amd64/libjemalloc.so.0...(no debugging symbols found)...done.
Loaded symbols for /opt/cprocsp/lib/amd64/libjemalloc.so.0
Reading symbols from /opt/cprocsp/lib/amd64/libcplib.so.4...(no debugging symbols found)...done.
Loaded symbols for /opt/cprocsp/lib/amd64/libcplib.so.4
Reading symbols from /libexec/ld-elf.so.1...(no debugging symbols found)...done.
Loaded symbols for /libexec/ld-elf.so.1
#0  0x0000000802597d46 in sbrk () from /lib/libc.so.7
[New Thread 804018400 (LWP 100106/<unknown>)]

теперь падает в кору,
помогите разобраться и решить проблему.
Offline 32stos  
#9 Оставлено : 25 января 2018 г. 11:04:56(UTC)
32stos

Статус: Участник

Группы: Участники
Зарегистрирован: 17.07.2015(UTC)
Сообщений: 24
Российская Федерация

Поблагодарили: 3 раз в 3 постах
Добрый день!

в rc.conf не нужно ничего записывать.
Я поставил на FreeBSD11 те же самые дистрибутивы, запустил руками postinstall и у меня всё нормально.
попробуйте убрать то, что вы внесли в rc.conf и запустить /sbin/ldconfig
Offline valaam123  
#10 Оставлено : 25 января 2018 г. 12:03:59(UTC)
valaam123

Статус: Участник

Группы: Участники
Зарегистрирован: 05.12.2013(UTC)
Сообщений: 27
Российская Федерация

Сказал(а) «Спасибо»: 2 раз
Убрал как Вы сказали из rc.conf
Код:

[root@unix /]# /sbin/ldconfig

[root@unix /opt/cprocsp/sbin/amd64]# ./postinstall.cades
License 0A202-U0030-00ECW-RRLMF-UU2WK is set
[ErrorCode: 0x00000000]
License TA200-G0030-00ECW-RRLNE-BTDVV is set
[ReturnCode: 0x00000000]

[root@unix /]# /opt/cprocsp/bin/amd64/ocsputil -V
ocsputil 2.0
[ReturnCode: 0x0]
Segmentation fault (core dumped)

обратите внимание FreeBSD 10.4-RELEASE GENERIC amd64
Offline valaam123  
#11 Оставлено : 6 апреля 2018 г. 14:02:24(UTC)
valaam123

Статус: Участник

Группы: Участники
Зарегистрирован: 05.12.2013(UTC)
Сообщений: 27
Российская Федерация

Сказал(а) «Спасибо»: 2 раз
Код:
# tsputil
Shared object "libcpalloc.so.0" not found, required by "tsputil" 


Почему дистрибутив для Freebsd не содержит нужных библиотек
cpro-rdr-64-4.0.9944_0.tbz/utar://opt/cprocsp/lib/amd64
Код:
|.dummy17         |      0 |февр. 21 23:48|
|libcapi10.so     |      0 |февр. 21 23:47|
|libcapi10.so.4   |  48754 |февр. 21 23:47|
|libcpui.so       |      0 |февр. 21 23:47|
|libcpui.so.4     |  25955 |февр. 21 23:47|
|librdrdsrf.so    |      0 |февр. 21 23:47|
|librdrdsrf.so.4  |  17171 |февр. 21 23:47|
|librdrfat12.so   |      0 |февр. 21 23:47|
|librdrfat12.so.4 |  43653 |февр. 21 23:47|
|librdrrdr.so     |      0 |февр. 21 23:47|
|librdrrdr.so.4   |  75138 |февр. 21 23:47|
|librdrrndm.so    |      0 |февр. 21 23:47|
|librdrrndm.so.4  |  16241 |февр. 21 23:47|
|librdrsup.so     |      0 |февр. 21 23:47|
|librdrsup.so.4   | 201290 |февр. 21 23:47|

В то время как для Linux набор библиотек больше ( в нем как раз есть недостающие библиотеки для tsputil и ocsputil)
...cprocsp-rdr-64_4.0.9944-5_amd64.deb/deb://CONTENTS/opt/cprocsp/lib/amd64
Код:
|@libcapi10.so          |      0|Feb 21 15:21|
|@libcapi10.so.4        |      0|Feb 21 15:21|
| libcapi10.so.4.0.4    |  48069|Feb 21 15:18|
|@libcpalloc.so         |      0|Feb 21 15:21|
|@libcpalloc.so.0       |      0|Feb 21 15:21|
| libcpalloc.so.0.0.0   |3577728|Feb 21 15:18|
|@libcpui.so            |      0|Feb 21 15:21|
|@libcpui.so.4          |      0|Feb 21 15:21|
| libcpui.so.4.0.4      |  23070|Feb 21 15:18|
|@librdrdsrf.so         |      0|Feb 21 15:21|
|@librdrdsrf.so.4       |      0|Feb 21 15:21|
| librdrdsrf.so.4.0.4   |  20917|Feb 21 15:18|
|@librdrfat12.so        |      0|Feb 21 15:21|
|@librdrfat12.so.4      |      0|Feb 21 15:21|
| librdrfat12.so.4.0.4  |  50467|Feb 21 15:18|
|@librdrrdr.so          |      0|Feb 21 15:21|
|@librdrrdr.so.4        |      0|Feb 21 15:21|
| librdrrdr.so.4.0.4    |  71968|Feb 21 15:18|
|@librdrrndm.so         |      0|Feb 21 15:21|
|@librdrrndm.so.4       |      0|Feb 21 15:21|
| librdrrndm.so.4.0.4   |  16305|Feb 21 15:18|
|@librdrsup.so          |      0|Feb 21 15:21|
|@librdrsup.so.4        |      0|Feb 21 15:21|
| librdrsup.so.4.0.4    | 212029|Feb 21 15:18|

например libcpalloc.so и другие, отсюда еще один вопрос Вы проводите тестирование на выпуске?

Отредактировано пользователем 6 апреля 2018 г. 14:20:48(UTC)  | Причина: Не указана

Offline 32stos  
#12 Оставлено : 11 апреля 2018 г. 14:44:24(UTC)
32stos

Статус: Участник

Группы: Участники
Зарегистрирован: 17.07.2015(UTC)
Сообщений: 24
Российская Федерация

Поблагодарили: 3 раз в 3 постах
Добрый день!

Действительно имеет место быть
Можно подложить библиотеки из предыдущей версии.
Offline valaam123  
#13 Оставлено : 11 апреля 2018 г. 18:54:34(UTC)
valaam123

Статус: Участник

Группы: Участники
Зарегистрирован: 05.12.2013(UTC)
Сообщений: 27
Российская Федерация

Сказал(а) «Спасибо»: 2 раз
Автор: 32stos Перейти к цитате

Можно подложить библиотеки из предыдущей версии.


какую версию вы имеете ввиду? 3.6?
дайте ссылку.

Отредактировано пользователем 11 апреля 2018 г. 18:55:24(UTC)  | Причина: Не указана

Offline valaam123  
#14 Оставлено : 12 апреля 2018 г. 3:26:22(UTC)
valaam123

Статус: Участник

Группы: Участники
Зарегистрирован: 05.12.2013(UTC)
Сообщений: 27
Российская Федерация

Сказал(а) «Спасибо»: 2 раз
если ставить бибилиотеки от 3.6
Код:
# tsputil
terminate called after throwing an instance of 'std::runtime_error'
  what():  locale::facet::_S_create_c_locale name not valid
Ловушка аварийного прекращения (стек памяти сброшен на диск)
Offline valaam123  
#15 Оставлено : 12 апреля 2018 г. 3:37:55(UTC)
valaam123

Статус: Участник

Группы: Участники
Зарегистрирован: 05.12.2013(UTC)
Сообщений: 27
Российская Федерация

Сказал(а) «Спасибо»: 2 раз
библиотеки от 3.9 приводят к той же ошибки.
Как то не серьезны, ваши отписки.
со стороны Вы профессионалы.
Offline Русев Андрей  
#16 Оставлено : 13 апреля 2018 г. 7:09:26(UTC)
Русев Андрей

Статус: Сотрудник

Группы: Администраторы, Участники
Зарегистрирован: 16.04.2008(UTC)
Сообщений: 471

Сказал(а) «Спасибо»: 1 раз
Поблагодарили: 75 раз в 63 постах
libcpalloc и libjemalloc надо брать из пакета cpro-rdr из предыдущего сертифицированного релиза: КриптоПро CSP 4.0.9842 (Riemann) от 15.11.2016:
https://www.cryptopro.ru...0/9842/freebsd-amd64.tgz
Техническую поддержку оказываем тут.
Наша база знаний.
Offline valaam123  
#17 Оставлено : 16 апреля 2018 г. 14:06:27(UTC)
valaam123

Статус: Участник

Группы: Участники
Зарегистрирован: 05.12.2013(UTC)
Сообщений: 27
Российская Федерация

Сказал(а) «Спасибо»: 2 раз
К сожалению эти библиотеки приводят к той же ошибке.
Offline valaam123  
#18 Оставлено : 17 апреля 2018 г. 10:18:43(UTC)
valaam123

Статус: Участник

Группы: Участники
Зарегистрирован: 05.12.2013(UTC)
Сообщений: 27
Российская Федерация

Сказал(а) «Спасибо»: 2 раз
А если попытаться установить этот дистрибутив 40/9842/freebsd-amd64.tgz (что вы приложили)
то при установке вот такие чудеса:
Код:
]# pkg install -y cpro-rdr-64-4.0.0_0.tbz
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
Checking integrity... done (0 conflicting)
The following 1 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
        cpro-rdr-64: 4.0.0_0

Number of packages to be installed: 1
[1/1] Installing cpro-rdr-64-4.0.0_0...
libiconv.so.3 was not found!
pkg: PRE-INSTALL script failed

соответственно ни чего не устанавливается.

Отредактировано пользователем 17 апреля 2018 г. 10:19:33(UTC)  | Причина: Не указана

Offline valaam123  
#19 Оставлено : 19 апреля 2018 г. 12:50:06(UTC)
valaam123

Статус: Участник

Группы: Участники
Зарегистрирован: 05.12.2013(UTC)
Сообщений: 27
Российская Федерация

Сказал(а) «Спасибо»: 2 раз
Автор: valaam123 Перейти к цитате
если ставить бибилиотеки от 3.6
Код:
# tsputil
terminate called after throwing an instance of 'std::runtime_error'
  what():  locale::facet::_S_create_c_locale name not valid
Ловушка аварийного прекращения (стек памяти сброшен на диск)


проблема оказалась в настройках локали, если вызвать так то работает без проблем
Код:
LANG=c /opt/cprocsp/bin/amd64/tsputil


в нашем случае локаль была:
Код:
LANG=ru_RU.KOI8-R

хотя с другой стороны почему ей не работать?? вопрос к разработчикам.
RSS Лента  Atom Лента
Пользователи, просматривающие эту тему
Быстрый переход  
Вы не можете создавать новые темы в этом форуме.
Вы не можете отвечать в этом форуме.
Вы не можете удалять Ваши сообщения в этом форуме.
Вы не можете редактировать Ваши сообщения в этом форуме.
Вы не можете создавать опросы в этом форуме.
Вы не можете голосовать в этом форуме.