logo
Добро пожаловать, Гость! Чтобы использовать все возможности Вход или Регистрация.

Уведомление

Icon
Error

Опции
К последнему сообщению К первому непрочитанному
Offline Burilas  
#1 Оставлено : 16 апреля 2018 г. 14:58:03(UTC)
Burilas

Статус: Активный участник

Группы: Участники
Зарегистрирован: 15.05.2015(UTC)
Сообщений: 32
Российская Федерация

Сказал(а) «Спасибо»: 3 раз
Поблагодарили: 1 раз в 1 постах
Здравствуйте

Пытаюсь подписать pdf. В процессе подписи создаю CMS, далее инициирую

Код:
final Signature signature = Signature.getInstance(JCP.GOST_EL_SIGN_NAME, JCSP.PROVIDER_NAME)


при этом падает ошибка, что не найдено провайдер JCSP

Код:
java.security.NoSuchProviderException: no such provider: JCSP
	at sun.security.jca.GetInstance.getService(GetInstance.java:83)
	at sun.security.jca.GetInstance.getInstance(GetInstance.java:206)
	at java.security.Signature.getInstance(Signature.java:355)


CSP на компьютере установлен версии 3.9.
Провайдер JCSP устанавливается с CSP? Как проверить, что провайдер JCSP присутствует на машине?

При установке JCP 1.0.54 в java не установился JCSP.jar, добавил его в ручную из дистрибутива JCP 2, чтобы было доступно имя провайдера через JCSP.PROVIDER_NAME. Корректно ли данное действие или как должен устанавливаться JCSP.jar?
Offline afev  
#2 Оставлено : 16 апреля 2018 г. 15:32:58(UTC)
afev


Статус: Сотрудник

Группы: Участники
Зарегистрирован: 06.12.2008(UTC)
Сообщений: 2,048
Откуда: Крипто-Про

Сказал(а) «Спасибо»: 10 раз
Поблагодарили: 264 раз в 262 постах
Здравствуйте.
JCSP.jar входит в состав отдельного дистрибутива java-jcsp-2.0.xxxxx: https://www.cryptopro.ru/products/csp/jcsp, не CSP, но работает с CSP (требует его установки).
Документация есть в папке Doc дистрибутива (архива). В 1.0.54 не входил, нужно устанавливать, например, отсюда: https://www.cryptopro.ru...ducts/csp/jcp/downloads, https://www.cryptopro.ru...p/java-csp-5.0.39267.zip
Offline Burilas  
#3 Оставлено : 17 апреля 2018 г. 7:13:34(UTC)
Burilas

Статус: Активный участник

Группы: Участники
Зарегистрирован: 15.05.2015(UTC)
Сообщений: 32
Российская Федерация

Сказал(а) «Спасибо»: 3 раз
Поблагодарили: 1 раз в 1 постах
У меня уже установлен JCP 1.0.54, если я сверху поставлю java-csp-5.0.39267.zip, который по сути является JCP 2.0, не будет ли каких-нибудь конфликтов?
Модуль подписания pdf, который я разрабатываю, будет на машине, на которой уже написана система работы со смэв 3, а там по их требованиям нужно JCP 1.0.54
Offline afev  
#4 Оставлено : 17 апреля 2018 г. 9:21:34(UTC)
afev


Статус: Сотрудник

Группы: Участники
Зарегистрирован: 06.12.2008(UTC)
Сообщений: 2,048
Откуда: Крипто-Про

Сказал(а) «Спасибо»: 10 раз
Поблагодарили: 264 раз в 262 постах
Автор: Burilas Перейти к цитате
У меня уже установлен JCP 1.0.54, если я сверху поставлю java-csp-5.0.39267.zip, который по сути является JCP 2.0, не будет ли каких-нибудь конфликтов?

java-csp-5.0.39267.zip - отдельный дистрибутив, его можно поставить вместо 1.0.54 (1.0.54 при этом будет удален, поэтому конфликтов между ними не должно быть). Если есть какое-то ПО, которое использует именно jcp 1.0.54, то конфликты могут быть.

Offline Burilas  
#5 Оставлено : 17 апреля 2018 г. 9:26:57(UTC)
Burilas

Статус: Активный участник

Группы: Участники
Зарегистрирован: 15.05.2015(UTC)
Сообщений: 32
Российская Федерация

Сказал(а) «Спасибо»: 3 раз
Поблагодарили: 1 раз в 1 постах
Спасибо за ответ. JCP 2.0 поддерживает какие версии java?

Отредактировано пользователем 17 апреля 2018 г. 10:39:17(UTC)  | Причина: Не указана

Offline afev  
#6 Оставлено : 17 апреля 2018 г. 11:52:41(UTC)
afev


Статус: Сотрудник

Группы: Участники
Зарегистрирован: 06.12.2008(UTC)
Сообщений: 2,048
Откуда: Крипто-Про

Сказал(а) «Спасибо»: 10 раз
Поблагодарили: 264 раз в 262 постах
Автор: Burilas Перейти к цитате
JCP 2.0 поддерживает какие версии java?

1.7, 1.8.

thanks 1 пользователь поблагодарил afev за этот пост.
Burilas оставлено 17.04.2018(UTC)
RSS Лента  Atom Лента
Пользователи, просматривающие эту тему
Быстрый переход  
Вы не можете создавать новые темы в этом форуме.
Вы не можете отвечать в этом форуме.
Вы не можете удалять Ваши сообщения в этом форуме.
Вы не можете редактировать Ваши сообщения в этом форуме.
Вы не можете создавать опросы в этом форуме.
Вы не можете голосовать в этом форуме.