logo
Добро пожаловать, Гость! Чтобы использовать все возможности Вход или Регистрация.

Уведомление

Icon
Error

Опции
К последнему сообщению К первому непрочитанному
Offline Сергей001  
#1 Оставлено : 12 марта 2018 г. 13:58:42(UTC)
Сергей001

Статус: Участник

Группы: Участники
Зарегистрирован: 22.01.2018(UTC)
Сообщений: 10

LinuxMint17 64bit. Chromium browser.

Используемая инструкция https://cpdn.cryptopro.r...ontent/cades/plugin.html

Скачал архив cades_linux_amd64.tar.gz
Распаковал, в нем 3 файла.

Проверил наличие cprocsp-rdr-gui-gtk. Есть.

Код:
dpkg -l | grep cprocsp-rdr-gui-gtk
ii  cprocsp-rdr-gui-gtk-64                  4.0.0-4                                            amd64        GUI components for CryptoPro CSP readers. Build 9842.


Проверил отсутствие cprocsp-rdr-gui. Отсутствует.
Код:
dpkg -l | grep cprocsp-rdr-gui
ii  cprocsp-rdr-gui-gtk-64                  4.0.0-4                                            amd64        GUI components for CryptoPro CSP readers. Build 9842.


Устанавливаю cprocsp-pki-2.0.0-amd64-cades.rpm. Косяк!

Код:
sudo alien -kci '/home/TERRA/Download/0/cprocsp-pki-2.0.0-amd64-cades.rpm' 
[sudo] пароль для sergen: 
Package build failed. Here's the log:
dh_testdir
dh_testdir
dh_testroot
dh_prep
dh_installdirs
dh_installdirs: Compatibility levels before 9 are deprecated (level 7 in use)
dh_installdocs
dh_installchangelogs
find . -maxdepth 1 -mindepth 1 -not -name debian -print0 | \
	xargs -0 -r -i cp -a {} debian/cprocsp-pki-cades
dh_compress
dh_makeshlibs
dh_installdeb
dh_installdeb: Compatibility levels before 9 are deprecated (level 7 in use)
dh_shlibdeps
dpkg-shlibdeps: ошибка: информация о зависимостях не найдена для /opt/cprocsp/lib/amd64/libcpalloc.so.0 (используется debian/cprocsp-pki-cades/opt/cprocsp/lib/amd64/libpkivalidator.so.2.0.0)
Подсказка: проверьте, действительно ли библиотеки из этого пакета.
dh_shlibdeps: dpkg-shlibdeps -Tdebian/cprocsp-pki-cades.substvars debian/cprocsp-pki-cades/opt/cprocsp/bin/amd64/ocsputil debian/cprocsp-pki-cades/opt/cprocsp/bin/amd64/tsputil debian/cprocsp-pki-cades/opt/cprocsp/lib/amd64/libcades.so.2.0.0 debian/cprocsp-pki-cades/opt/cprocsp/lib/amd64/libcppcades.so.2.0.0 debian/cprocsp-pki-cades/opt/cprocsp/lib/amd64/libocsp.so.2.0.0 debian/cprocsp-pki-cades/opt/cprocsp/lib/amd64/libocspcli.so.2.0.0 debian/cprocsp-pki-cades/opt/cprocsp/lib/amd64/libphpcades.so.2.0.0 debian/cprocsp-pki-cades/opt/cprocsp/lib/amd64/libpkivalidator.so.2.0.0 debian/cprocsp-pki-cades/opt/cprocsp/lib/amd64/libtsp.so.2.0.0 debian/cprocsp-pki-cades/opt/cprocsp/lib/amd64/libtspcli.so.2.0.0 debian/cprocsp-pki-cades/opt/cprocsp/lib/amd64/libxmlsec-mscrypto.so.2.0.0 debian/cprocsp-pki-cades/opt/cprocsp/lib/amd64/libxmlsec.so.2.0.0 returned exit code 2
debian/rules:17: ошибка выполнения рецепта для цели «binary-arch»
make: [binary-arch] Ошибка 2 (игнорирование)
dh_gencontrol
dpkg-gencontrol: предупреждение: Depends поле из пакета cprocsp-pki-cades: неизвестная подстановочная переменная ${shlibs:Depends}
dh_md5sums
dh_builddeb
dpkg-deb: ошибка: каталог control имеет недопустимые права доступа 777 (должно быть >=0755 и <=0775)
dh_builddeb: dpkg-deb --build debian/cprocsp-pki-cades .. returned exit code 2
debian/rules:17: ошибка выполнения рецепта для цели «binary-arch»
make: *** [binary-arch] Ошибка 1


В чем проблема ?

Попутно хочу спросить, работает ли Rutoken версии 2.0 на Linux ? Нужно ли для этого ключа устанавливать на компьютер криптопровайдер или достаточно плагина для браузера ?
Offline Агафьин Сергей  
#2 Оставлено : 13 марта 2018 г. 9:08:35(UTC)
Агафьин Сергей

Статус: Сотрудник

Группы: Участники
Зарегистрирован: 12.08.2013(UTC)
Сообщений: 386
Мужчина
Российская Федерация
Откуда: Москва

Поблагодарили: 62 раз в 58 постах
Автор: Сергей001 Перейти к цитате

Попутно хочу спросить, работает ли Rutoken версии 2.0 на Linux ? Нужно ли для этого ключа устанавливать на компьютер криптопровайдер или достаточно плагина для браузера ?


Работает из коробки. Нужно поставить два обязательных пакета: cprocsp-rdr-pcsc и cprocsp-rdr-rutoken.
С уважением,
Сергей Агафьин,
Начальник отдела разработки ФКН.
Техническую поддержку оказываем здесь.
Наша база знаний.
Offline Андрей Емельянов  
#3 Оставлено : 13 марта 2018 г. 9:16:35(UTC)
Андрей Емельянов

Статус: Сотрудник

Группы: Участники
Зарегистрирован: 11.03.2013(UTC)
Сообщений: 740
Мужчина
Российская Федерация
Откуда: Оттуда

Сказал «Спасибо»: 1 раз
Поблагодарили: 136 раз в 133 постах
Добрый день.
У Вас было похожее сообщение:
https://www.cryptopro.ru...ts&m=88777#post88777
Проблема с конвертацией пакетов в deb инструментом alien. Разберитесь с утилитой alien или конвертируйте другим способом.

Цитата:
Попутно хочу спросить, работает ли Rutoken версии 2.0 на Linux ? Нужно ли для этого ключа устанавливать на компьютер криптопровайдер или достаточно плагина для браузера ?

Плагин будет работать только с криптопровайдером.
Техническую поддержку оказываем тут
Наша база знаний
RSS Лента  Atom Лента
Пользователи, просматривающие эту тему
Быстрый переход  
Вы не можете создавать новые темы в этом форуме.
Вы не можете отвечать в этом форуме.
Вы не можете удалять Ваши сообщения в этом форуме.
Вы не можете редактировать Ваши сообщения в этом форуме.
Вы не можете создавать опросы в этом форуме.
Вы не можете голосовать в этом форуме.