logo
Добро пожаловать, Гость! Чтобы использовать все возможности Вход или Регистрация.

Уведомление

Icon
Error

Опции
К последнему сообщению К первому непрочитанному
Offline azorinmsu  
#1 Оставлено : 25 апреля 2017 г. 10:40:02(UTC)
azorinmsu

Статус: Новичок

Группы: Участники
Зарегистрирован: 09.01.2017(UTC)
Сообщений: 5

Добрый день, кто-нибудь разворачивал данный инструмент, может быть есть скрипты для создании базы данных?
Offline tomas  
#2 Оставлено : 5 мая 2017 г. 0:58:19(UTC)
tomas

Статус: Новичок

Группы: Участники
Зарегистрирован: 05.05.2017(UTC)
Сообщений: 2
Российская Федерация

Пробую развернуть.
Он у меня xsd-схемы принимает только если они из одного файла состоят. Если же есть импорты, то не может распарсить.
Offline tomas  
#3 Оставлено : 22 мая 2017 г. 0:58:09(UTC)
tomas

Статус: Новичок

Группы: Участники
Зарегистрирован: 05.05.2017(UTC)
Сообщений: 2
Российская Федерация

Получил ответ от разработчиков.
Схемы состоящие из нескольких файлов (с элементом import) не поддерживаются.
А таковых схем большинство.
Offline incognito  
#4 Оставлено : 25 августа 2017 г. 12:25:31(UTC)
incognito

Статус: Новичок

Группы: Участники
Зарегистрирован: 25.08.2017(UTC)
Сообщений: 1

Доброго времени суток! У меня другой вопрос по этому же адаптеру. Как использовать его с КриптоПро JCP 1.0.54, для работы которого требуется JDK до 1.7.0_25, если запуск адаптера на данной версии JDK завершается с ошибкой:

Exception in thread "main" java.util.ServiceConfigurationError: ru.voskhod.smev.adapter.api.transport.TransportLoader: Provider ru.voskhod.smev.adapter.transport.TransportLoaderImpl could not be instantiated: java.lang.UnsupportedClassVersionError: ru/voskhod/smev/client/api/services/template/configuration/TemplateConfiguration : Unsupported major.minor version 52.0

Т.е. получается, что для работы адаптера нужна JDK 8, хотя в официальной документации написано, что требуется JDK 1.7 и выше?
Offline gysek  
#5 Оставлено : 28 ноября 2017 г. 9:19:32(UTC)
gysek

Статус: Новичок

Группы: Участники
Зарегистрирован: 08.02.2017(UTC)
Сообщений: 3
Откуда: Новосибирск

Автор: incognito Перейти к цитате
Доброго времени суток! У меня другой вопрос по этому же адаптеру. Как использовать его с КриптоПро JCP 1.0.54, для работы которого требуется JDK до 1.7.0_25, если запуск адаптера на данной версии JDK завершается с ошибкой:

Exception in thread "main" java.util.ServiceConfigurationError: ru.voskhod.smev.adapter.api.transport.TransportLoader: Provider ru.voskhod.smev.adapter.transport.TransportLoaderImpl could not be instantiated: java.lang.UnsupportedClassVersionError: ru/voskhod/smev/client/api/services/template/configuration/TemplateConfiguration : Unsupported major.minor version 52.0

Т.е. получается, что для работы адаптера нужна JDK 8, хотя в официальной документации написано, что требуется JDK 1.7 и выше?


Для адаптера 1.8 для JCP ставите 1.7 (это судя по коду в исходниках)




RSS Лента  Atom Лента
Пользователи, просматривающие эту тему
Быстрый переход  
Вы не можете создавать новые темы в этом форуме.
Вы не можете отвечать в этом форуме.
Вы не можете удалять Ваши сообщения в этом форуме.
Вы не можете редактировать Ваши сообщения в этом форуме.
Вы не можете создавать опросы в этом форуме.
Вы не можете голосовать в этом форуме.