Ключевое слово в защите информации
КЛЮЧЕВОЕ СЛОВО
в защите информации
Получить ГОСТ TLS-сертификат для домена (SSL-сертификат)
Добро пожаловать, Гость! Чтобы использовать все возможности Вход или Регистрация.

Уведомление

Icon
Error

Опции
К последнему сообщению К первому непрочитанному
Offline rudnin  
#1 Оставлено : 29 декабря 2021 г. 22:03:02(UTC)
rudnin

Статус: Участник

Группы: Участники
Зарегистрирован: 29.12.2021(UTC)
Сообщений: 14

Сказал(а) «Спасибо»: 1 раз
никак не могу окончательно собрать расширение...

конфигурация CentOS 7, php7.4

устанавливал по инструкции от разработчика


lsb-cprocsp-rdr-64-5.0.12000-6.x86_64
cprocsp-curl-64-5.0.12000-6.x86_64
cprocsp-pki-phpcades-64-2.0.14458-1.x86_64
lsb-cprocsp-base-5.0.12000-6.noarch
lsb-cprocsp-kc1-64-5.0.12000-6.x86_64
lsb-cprocsp-ca-certs-5.0.12000-6.noarch
lsb-cprocsp-devel-5.0.12000-6.noarch
cprocsp-pki-cades-64-2.0.14458-1.x86_64
cprocsp-pki-plugin-64-2.0.14458-1.x86_64
lsb-cprocsp-capilite-64-5.0.12000-6.x86_64
cprocsp-rdr-gui-gtk-64-5.0.12000-6.x86_64

эти пакеты поставились без ошибок, компиляция расширения проходит без ошибок, однако PHP не может подключить расширение

PHP Warning: PHP Startup: Unable to load dynamic library 'libphpcades.so' (tried: /opt/remi/php74/root/usr/lib64/php/modules/libphpcades.so (/opt/remi/php74/root/usr/lib64/php/modules/libphpcades.so: undefined symbol: zend_get_std_object_handlers), /opt/remi/php74/root/usr/lib64/php/modules/libphpcades.so.so (/opt/remi/php74/root/usr/lib64/php/modules/libphpcades.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP 7.4.27 (cli) (built: Dec 14 2021 17:17:06) ( NTS )
Copyright (c) The PHP Group

символьная ссылка установлена
ln -s /opt/cprocsp/src/phpcades/libphpcades.so /opt/remi/php74/root/usr/lib64/php/modules/libphpcades.so

так же не понятно почему libphpcades.so.so ...

и еще, скачивалась патчилась версия php7.2, потому что патч на версию 7.4 патчить не хотел... может поэтому расширение не хочет включаться?

помогите пожалуйста, бьюсь уже 4 день Brick wall Liar

Offline two_oceans  
#2 Оставлено : 30 декабря 2021 г. 7:24:02(UTC)
two_oceans

Статус: Эксперт

Группы: Участники
Зарегистрирован: 05.03.2015(UTC)
Сообщений: 1,536
Российская Федерация
Откуда: Иркутская область

Сказал(а) «Спасибо»: 105 раз
Поблагодарили: 375 раз в 354 постах
Автор: rudnin Перейти к цитате
так же не понятно почему libphpcades.so.so ...
Добрый день. Просто не так читаете предупреждение:
Код:
PHP Warning: PHP Startup: Unable to load dynamic library 'libphpcades.so' (tried:

это начало
Код:
/opt/remi/php74/root/usr/lib64/php/modules/libphpcades.so (/opt/remi/php74/root/usr/lib64/php/modules/libphpcades.so: undefined symbol: zend_get_std_object_handlers),
это первая попытка найти библиотеку, библиотека нашлась! Однако не подошла по требованиям php
Код:
/opt/remi/php74/root/usr/lib64/php/modules/libphpcades.so.so (/opt/remi/php74/root/usr/lib64/php/modules/libphpcades.so.so: cannot open shared object file: No such file or directory)

это вторая попытка найти библиотеку - некоторые забывают указать стандартное расширение библиотеки, поэтому php пробует к указанному в конфиге пути "дописать на удачу" еще один раз расширение библиотеки. Естественно такой нет. Если первая попытка будет удачна, то до такого просто не дойдет, так что правильней думать не про .so.so и место линковки, а как сделать первую попытку успешной.
Код:
) in Unknown on line 0
Цитата:
и еще, скачивалась патчилась версия php7.2, потому что патч на версию 7.4 патчить не хотел... может поэтому расширение не хочет включаться?
Скорее всего да, "undefined symbol: end_get_std_object_handlers" это ошибка из-за которой первая попытка поиска не смогла загрузить библиотеку и очень похоже на несоответствие версии.
Цитата:
помогите пожалуйста, бьюсь уже 4 день

Отредактировано пользователем 30 декабря 2021 г. 7:26:36(UTC)  | Причина: Не указана

Offline rudnin  
#3 Оставлено : 30 декабря 2021 г. 11:17:38(UTC)
rudnin

Статус: Участник

Группы: Участники
Зарегистрирован: 29.12.2021(UTC)
Сообщений: 14

Сказал(а) «Спасибо»: 1 раз
Автор: two_oceans Перейти к цитате
Автор: rudnin Перейти к цитате
так же не понятно почему libphpcades.so.so ...
Добрый день. Просто не так читаете предупреждение:
Код:
PHP Warning: PHP Startup: Unable to load dynamic library 'libphpcades.so' (tried:

это начало
Код:
/opt/remi/php74/root/usr/lib64/php/modules/libphpcades.so (/opt/remi/php74/root/usr/lib64/php/modules/libphpcades.so: undefined symbol: zend_get_std_object_handlers),
это первая попытка найти библиотеку, библиотека нашлась! Однако не подошла по требованиям php
Код:
/opt/remi/php74/root/usr/lib64/php/modules/libphpcades.so.so (/opt/remi/php74/root/usr/lib64/php/modules/libphpcades.so.so: cannot open shared object file: No such file or directory)

это вторая попытка найти библиотеку - некоторые забывают указать стандартное расширение библиотеки, поэтому php пробует к указанному в конфиге пути "дописать на удачу" еще один раз расширение библиотеки. Естественно такой нет. Если первая попытка будет удачна, то до такого просто не дойдет, так что правильней думать не про .so.so и место линковки, а как сделать первую попытку успешной.
Код:
) in Unknown on line 0
Цитата:
и еще, скачивалась патчилась версия php7.2, потому что патч на версию 7.4 патчить не хотел... может поэтому расширение не хочет включаться?
Скорее всего да, "undefined symbol: end_get_std_object_handlers" это ошибка из-за которой первая попытка поиска не смогла загрузить библиотеку и очень похоже на несоответствие версии.
Цитата:
помогите пожалуйста, бьюсь уже 4 день

спасибо, попробуем понизить версию
RSS Лента  Atom Лента
Пользователи, просматривающие эту тему
Быстрый переход  
Вы не можете создавать новые темы в этом форуме.
Вы не можете отвечать в этом форуме.
Вы не можете удалять Ваши сообщения в этом форуме.
Вы не можете редактировать Ваши сообщения в этом форуме.
Вы не можете создавать опросы в этом форуме.
Вы не можете голосовать в этом форуме.