Ключевое слово в защите информации
КЛЮЧЕВОЕ СЛОВО
в защите информации
Получить ГОСТ TLS-сертификат для домена (SSL-сертификат)
Добро пожаловать, Гость! Чтобы использовать все возможности Вход или Регистрация.

Уведомление

Icon
Error

Опции
К последнему сообщению К первому непрочитанному
Offline rebeled  
#1 Оставлено : 25 ноября 2021 г. 20:48:41(UTC)
rebeled

Статус: Участник

Группы: Участники
Зарегистрирован: 05.12.2016(UTC)
Сообщений: 10

Сказал(а) «Спасибо»: 4 раз
Поблагодарили: 1 раз в 1 постах
Не могу заставить работать плагин в Опере на linux. В остальных браузерах работает.
На тестовой странице
https://cryptopro.ru/sit...ge/cades_bes_sample.html
Видит extention, но не видит плагин
В nmcades_plugin_api.js
в функции
Цитата:

function CreatePluginObject()
{
//create message structure
g_request_id++;
const docURL = window.document.URL;
object_messsage = {destination:"nmcades", requestid: g_request_id, type: "init", url: docURL};
cpcsp_console_log(cadesplugin.LOG_LEVEL_DEBUG, "nmcades_plugin_api.js: Sent message:" + JSON.stringify(object_messsage));
const requestPromise = new Promise ( function (resolve, reject) {
g_resolve_function[g_request_id] = resolve;
g_reject_function[g_request_id] = reject;
window.postMessage( object_messsage, "*");
});
return requestPromise.then(function (result) {
obj = {};
obj['objid'] = result.data.value;
obj.CreateObjectAsync = CallMethod.bind(obj, "CreateObject");
return obj;
});
}

Отправляется postMessage но в ответ на него приходит:
postMessage received by 'Пример использования КриптоПро ЭЦП Browser plug-in' from 'https://cryptopro.ru' with data: EnableInternalCSP=undefined

Цитата:

dpkg -l |grep cpro
ii cprocsp-compat-debian 1.0.0-1 all CryptoPro CSP compatibility extension for non-LSB Debian/Ubuntu
ii cprocsp-curl-64 4.0.0-4 amd64 CryptoPro Curl shared library and binaris. Build 9842.
ii cprocsp-pki-cades-64 2.0.14368-1 amd64 CryptoPro ECP SDK
ii cprocsp-pki-phpcades-64 2.0.14368-1 amd64 CryptoPro ECP SDK PHP extension
ii cprocsp-pki-plugin-64 2.0.14368-1 amd64 CryptoPro ECP Browser plug-in
ii cprocsp-rdr-gui-gtk-64 4.0.0-4 amd64 GUI components for CryptoPro CSP readers. Build 9842.
ii libbcprov-java 1.61-1 all Bouncy Castle Java Cryptographic Service Provider
ii lsb-cprocsp-base 4.0.0-4 all CryptoPro CSP library. Build 9842.
ii lsb-cprocsp-capilite-64 4.0.0-4 amd64 CryptoAPI lite. Build 9842.
ii lsb-cprocsp-kc1-64 4.0.0-4 amd64 CryptoPro CSP library. Build 9842.
ii lsb-cprocsp-rdr-64

Переустановка плагина не помогает. Куда копать?

Ответ: https://www.cryptopro.ru...&m=129104#post129104
Через snap плагин не работает

Отредактировано пользователем 26 ноября 2021 г. 11:41:36(UTC)  | Причина: Не указана

Offline Санчир Момолдаев  
#2 Оставлено : 25 ноября 2021 г. 21:57:26(UTC)
Санчир Момолдаев

Статус: Сотрудник

Группы: Модератор, Участники
Зарегистрирован: 03.12.2018(UTC)
Сообщений: 807
Российская Федерация

Сказал(а) «Спасибо»: 70 раз
Поблагодарили: 164 раз в 160 постах
Добрый день!
уточните расширение из магазина опера?
опера не из snap/flathub?
Техническую поддержку оказываем тут
Наша база знаний
Offline rebeled  
#3 Оставлено : 25 ноября 2021 г. 23:41:41(UTC)
rebeled

Статус: Участник

Группы: Участники
Зарегистрирован: 05.12.2016(UTC)
Сообщений: 10

Сказал(а) «Спасибо»: 4 раз
Поблагодарили: 1 раз в 1 постах
Автор: Санчир Момолдаев Перейти к цитате
Добрый день!
уточните расширение из магазина опера?
опера не из snap/flathub?

Расширение из магазина опера. Из магазина гугла ставил случайно - не видит расширения(там айди расширения вшит на странице примера)
Опера из snap
ADD. В Chromium из snap так же не работает. Работает в хроме и фаерфоксе
ADD2. В опере установленной через sudo apt install opera-stable заработало, но уточните плиз на будущее, будет ли плагин работатьв браузерах через snap

Отредактировано пользователем 26 ноября 2021 г. 0:07:42(UTC)  | Причина: Не указана

Offline Санчир Момолдаев  
#4 Оставлено : 26 ноября 2021 г. 11:21:42(UTC)
Санчир Момолдаев

Статус: Сотрудник

Группы: Модератор, Участники
Зарегистрирован: 03.12.2018(UTC)
Сообщений: 807
Российская Федерация

Сказал(а) «Спасибо»: 70 раз
Поблагодарили: 164 раз в 160 постах
через снап не заработает, т.к. браузер изолирован и нет доступа к файловой системе где провайдер
через флатпак может заработать, но нужно дать права
Техническую поддержку оказываем тут
Наша база знаний
thanks 1 пользователь поблагодарил Санчир Момолдаев за этот пост.
rebeled оставлено 26.11.2021(UTC)
Offline nickm  
#5 Оставлено : 26 ноября 2021 г. 11:23:54(UTC)
nickm

Статус: Активный участник

Группы: Участники
Зарегистрирован: 31.05.2016(UTC)
Сообщений: 225

Сказал(а) «Спасибо»: 71 раз
Поблагодарили: 44 раз в 41 постах
Автор: Санчир Момолдаев Перейти к цитате
через снап не заработает, т.к. браузер изолирован и нет доступа к файловой системе где провайдер
через флатпак может заработать, но нужно дать права


Хех, вот будет наплыв пользователей с вопросами в тех.поддержку, когда эти "магазины" автономных приложений заполонят все Linux-дисрибутивы.
Offline rebeled  
#6 Оставлено : 26 ноября 2021 г. 11:42:12(UTC)
rebeled

Статус: Участник

Группы: Участники
Зарегистрирован: 05.12.2016(UTC)
Сообщений: 10

Сказал(а) «Спасибо»: 4 раз
Поблагодарили: 1 раз в 1 постах
Автор: Санчир Момолдаев Перейти к цитате
через снап не заработает, т.к. браузер изолирован и нет доступа к файловой системе где провайдер
через флатпак может заработать, но нужно дать права


Спасибо, поправил тему, чтобы быстрее гуглилось
RSS Лента  Atom Лента
Пользователи, просматривающие эту тему
Быстрый переход  
Вы не можете создавать новые темы в этом форуме.
Вы не можете отвечать в этом форуме.
Вы не можете удалять Ваши сообщения в этом форуме.
Вы не можете редактировать Ваши сообщения в этом форуме.
Вы не можете создавать опросы в этом форуме.
Вы не можете голосовать в этом форуме.